Chromium Image Issues after Updating Server



  • New thread spawned from my previous post about upgrade issues. I’m not able to use my old Chromium issues after upgrade and also not able to successfully create and restore Chromium images after upgrade. Windows images seem to be working fine.


  • Developer

    @rstockham23 Sorry but the important information is not on the picture. Usually there is a message in the blue partclone screen which should give is more hints on what’s wrong. When scheduling the task you can set the checkbox for debug and after the error happens you’ll get to a command shell. There you can check the mentioned log file: cat /var/log/partclone.log


  • Moderator

    @rstockham23 Can you post a screenshot of the image settings?

    Are there any special settings for this host? (eg kernel arguments and the like)



  • Attached is a photo of the error that we’re still getting even after doing a fresh install of the latest version of FOG. I still can’t Capture a Chromium image without getting an error. Same FOG server works just fine with Windows images, etc, but not with Chromium.0_1529328503496_20180601_122141.jpg


  • Senior Developer

    Init’s are now uploaded.

    If you aren’t willing to jump to the working branch, please run:

    wget --no-check-certificate -O /var/www/fog/service/ipxe/init.xz https://fogproject.org/inits/init.xz
    wget --no-check-certificate -O /var/www/fog/service/ipxe/init_32.xz https://fogproject.org/inits/init_32.xz
    

    This should get you the latest init’s with the changes @Sebastian-Roth has suggested.


  • Senior Developer

    I’m currently updating the init’s with the requested changes as proposed. Will be a few more minutes or so, sorry.

    Hopefully this will fix the partition uuid setting for chromium os (among others).


  • Developer

    @rstockham23 Are you still seeing the issue No image file(s) found when trying to deploy a fresh Chromium OS image captured with FOG 1.4.4. I just can’t reproduce the issue. It’s working great for me.

    Now about the other things. The ACPI messages in your video tell us that the Linux kernel is not happy with your UEFI firmware but that’s not a real issue. You can ignore those.

    About the Partition type/uuid being set to: Since Chromium OS has more than 10 partitions our regular expression match kind of freaked out and found several matches. I will push a fix soon.

    The Can not open file '...d1.original.swapuuids' has been another issue that I’ll post a fix. Thanks for bringing those up!

    @Tom-Elliott @Joe-Schmitt Please check out the proposed fixes and build fresh inits with those when you have time to do so.


  • Developer

    @rstockham23 Sorry for taking so long to get back to you. I now got a test setup up and will look into it. Hope I find enough time over the weekend.



  • @sebastian-roth Thanks Sebastian. I had since deleted the 2018CloudReady image, but later created another one with the exact same results. It is called NewCloudReady. Below is the contents of it’s directory and attached is a picture of the image setup:

    total 1872496
    32 d1.mbr
    4 d1.original.uuids
    4 d1p10.img
    4 d1p11.img
    4 d1p12.img
    4 d1p13.img
    4 d1p14.img
    4 d1p15.img
    407092 d1p16.img
    6588 d1p17.img
    713284 d1p18.img
    6588 d1p19.img
    4 d1p1.img
    713284 d1p20.img
    4 d1p21.img
    4 d1p22.img
    11860 d1p23.img
    4 d1p24.img
    4 d1p25.img
    128 d1p26.img
    13552 d1p27.img
    4 d1p2.img
    4 d1p3.img
    4 d1p4.img
    4 d1p5.img
    4 d1p6.img
    4 d1p7.img
    4 d1p8.img
    4 d1p9.img
    8 d1.partitions
    0 directory.txt

    Screenshot: https://photos.app.goo.gl/BM5R39AVgvhvOBg32


  • Developer

    @rstockham23 I didn’t find the time to set a whole test system up to try and replicate the issue but looking at the videos and pictures you posted I noticed something. Moving an image from 1.3.5 is one thing. But let’s start with what you posted last. An image taken with FOG 1.4.4 and trying to deploy errors out with No image file(s) found: In that picture I see ... image=2018CloudRetype=down at the end of the kernel command line. The image option is cut and there a quite some options missing. As well mac= is empty. So I am wondering what’s wrong here. Never seen this before.

    Can you please post a listing of the image directory: ls -al /images/2018CloudReady and take a screenshot of the image settings in the web UI. Post both here so we can check.


  • Developer

    @rstockham23 Ok, moved posts over. I’ll look into this tomorrow.



  • @george1421 Your comments gave me an idea that I hadn’t tried yet. The images I’ve been using so far are all ones that were originally created in fog 1.3.5. So I went ahead and created an entirely new image file from scratch and uploaded from a working Chromium laptop like I normally would. All messages showed successful for the upload, etc. I then went to download the image to another laptop and got this error message before it started the download:
    https://photos.app.goo.gl/I75ORDRoDZqf24OU2

    So it would seem now that with my current server it’s not successfully creating new Chromium images from scratch either.



  • @george1421 Thank you. I will take that advice to heart!


  • Moderator

    @rstockham23 reverting to a previous build is not usually supported. Moving from 1.4.x to 1.3.0 wouldn’t be advised. What I’m speculating is that 1.4.4 is expecting something to be in that uuid file that is not currently there. The developers spent many hours improving disk imaging and resizing between 1.4.1 and 1.4.4. I think the fix is pretty easy we just need to identify what is missing. With 1.5.0 (stable) nearing release I don’t think moving backwards is the best choice right now.



  • @george1421 @Wayne-Workman I appreciate you guys looking at this. Like I said in my original message, this has never been a problem in the past. It just worked, but since updating it just won’t boot correctly. If you’re wanting to try and duplicate on your end. The easiest to download installer for Chromium and the particular version that I’m using in this case can be found here: https://www.neverware.com/freedownload

    @Wayne-Workman you had mentioned going back through different versions of Fog…I have never tried to Back-Rev Fog before. Can that be done gracefully by simply installing an old version over top of a newer version or is that a recipe for disaster?



  • Posting the link to the Chromium OS project in case future readers are interested:
    https://www.chromium.org/chromium-os

    I went through the documentation myself years ago and back then, it was really difficult to understand - I had to jump around in the instructions to get things going on the hardware I was working with (elite books).

    Old thread about the HP Elite Books with Chromium OS on them:
    https://forums.fogproject.org/topic/6214/chromiumos-r48-elitebook-8730w

    @george1421 I provided a ton of disk related output in that thread.


  • Moderator

    @rstockham23 Well I don’t 100% understand what I’m looking at, but I do see an anomaly in the data in the uuid file. Why is /dev/sda16 different than 15 and 17? Same with sda17 and sda23

    That’s just an open question. I need to see now if your video gives me any more detail knowing now what we know.



  • @george1421 said in Upgraded an Existing Server to 1.4.4 and Now Interface is Very Slow and Chromium Images are not working:

    Color me shocked, but Chromium has 20 partitions??

    Yes. I can confirm from experience.



  • @george1421 Yes sir…it’s an OS of many partitions. Here is the other output you requested:

    /dev/sda 0eac06b1-8867-d143-a213-146cf0f7b6ca
     1:1f6b7189-fbfe-4d49-83fc-8c50ef9001aa
     2:150a93be-3c90-0f47-9d33-a8c9f7e6e3b7
     3:96d4a3a5-298a-e54d-94fd-665a6d227172
     4:46338198-7637-6d46-82af-667ee26b327e
     5:550e0544-b3ce-bd49-a8f8-18b4138f2cdf
     6:17631450-4b4c-c945-9b0d-052dace7d343
     7:e32bfeb9-959f-424b-9209-97fecdcc54ff
     8:e7d02ac5-3818-1a4a-b243-c90db73d2a95
     9:7a788ce4-39e2-f549-9218-fc5d692ce30c
     10:c8f219b3-bb32-e143-a690-98b9b30a8129
     11:38be338c-94ea-0c49-a404-2b7c10807d94
     12:51f906e6-4287-a445-86d9-4d79bdf0ec59
     13:22f188ee-3584-9c47-8feb-c285673827de
     14:5c35e129-7808-2b41-8355-7caae0d5eb0e
     15:5083a3c4-5faf-3a4e-a986-54a3f369e053
    /dev/sda16 16:066670c1-582e-457c-8023-bf0d8de662fc 16:04cd822c-013d-f443-8104-d6c5e5fd6862
     17:849ad749-9ea9-d940-9abe-04415e7d7a3d
     18:726616f9-9587-d14c-9acf-3410b0945046
     19:b31444ef-4417-234b-a848-8382c0340c2f
     20:126a9bc8-c55d-2c4a-9632-ccf8b883a294
     21:b9a205ee-743b-604d-9b42-a763fb667219
     22:f9ee26d3-5a6f-f94e-9071-3f333d0486b3
    /dev/sda23 23:ebc2c96f-7b00-404f-9eeb-e567ea639dbb 23:c5a29595-fb6a-0f40-b693-852d6f73b502
     24:4a50ed90-1d40-2245-b441-d7f0d8361fa1
     25:a8d9ce8b-ea02-c942-a2e4-75f04fb2b62e
     26:ed6c6e28-acf7-e04b-91fe-23dcc222a05a
    /dev/sda27 27:BA20-3347 27:71053a51-16c1-2b46-a5d6-25116cf1cb8f
    

  • Moderator

    @rstockham23 Color me shocked, but Chromium has 20 partitions?? That does explain what is visible in the video a bit more.

    can we also get a cat of the d1.original.uuids file


 

458
Online

41.9k
Users

12.5k
Topics

117.6k
Posts