DHCP, TFTP, PXE oh my!



  • Hi all,

    I am relatively new to the FOG environment. I have set up the following:

    ESX Ubuntu 16.04LTS with Fog Server: 1.4.4

    Issue: Failed DHCP address requests from client post PXE boot.

    I have an interesting environment that I am attempting to tackle. I maintain approximately 100 kiosks and am implementing FOG to handle imaging for them to free up my technicians for other critical systems.

    I have 100 kiosks spread across 3 switches.

    0_1517528431073_Fog Environment.jpg

    This is what I am seeing occur on clients 41-100 (Sorry that the pics are not better quality)

    0_1517528506478_FogClient.jpg

    Any ideas what could be causing my difficulties?

    Thanks,

    Robert



  • Hey Guys, thanks for leading me in the correct direction… one of our NEs worked with me today, what we found was… well… lets just say that I am glad I am a server engineer and not a network engineer.

    We config’ed one port for Spanning tree fast port and it connects correctly. Now I have to go back to my Sys Eng and ask him WTF?!?!

    Thanks again,

    Rbryant


  • Developer

    @rbryant Use a mini switch as suggested and we sure see within a very short time if my intuition leads us the right way. Looking into port speed and spanning tree settings might cost you two hours if you don’t know what exactly you are looking for.


  • Moderator

    @rbryant said in DHCP, TFTP, PXE oh my!:

    I will get together with the network engineer and discuss testing the port speed settings.

    Not port speed, but if spanning tree is enabled and you are not using one of the fast spanning tree protocols like RSTP, MSTP, Fast-STP or what ever your switch manufacturer calls it.



  • Hi Sebastian,

    I am using the DHCP feature on FOG. I will get together with the network engineer and discuss testing the port speed settings.

    rbryant


  • Developer

    @rbryant Your issue on SW2 and SW3 sounds like it could be caused by:

    • Spanning tree issue (make sure to configure RSTP and/or “port fast”)
    • Auto-negotiation issue (try configuring static speed instead of auto-negotiation for that port)
    • Ethernet energy saving (see if your switch has EEE/802.3az feature and disable if possible)

    The quick fix is to connect an unmanaged mini switch between your kiosk client and the “main” switch (SW2 / SW3). This way you can mask the problem if it really is one mentioned above. Give it a try and let us know.

    Beside that, what is serving DHCP in your network? Windows DHCP server, some kind of router or is it your FOG server?


 

574
Online

5.4k
Users

12.6k
Topics

118.9k
Posts