NFS mount options needed.



  • Long story short; I run the FOG-service in a Virtual Machine, hence I have trouble with slooow NFS-mounts, resulting in “Connection Timed Out” when mounting /images/dev.

    (Edit: Some packets never arrive, ‘showmount -e <fog ip>’ responds but after 2 min and 10 sec. Connections times out.)

    I’ve tested different scenarios the last week, and problem with the mount can be bypassed by setting mount options on the NFS-client:

    mount -v -t nfs -o vers=3,nolock,udp <fog ip>:/images/dev /images
    

    Here is my setup:

    • FOG-server runs up-to-date devbranch, in a Debian 9 on a Virtual Box Guest in Network Bridge Mode.
    • My Synology works as Storage node and got correct permissions - I can mount manually with above string.
    • DHCP is on my router running DD-wrt with option 66,67 enabled and the PXE-boot part, part is working flawlessly.

    Question: Can I set the mount string in a config somehow?
    Plan B: Can I define alternate mount types, like CIFS or SMB anywhere?

    If you need anything, let me know.
    Thanks :)
    //Fred

    (Edit 2: Thanks to Tom Elliot for this great work and thanks to all other devs, bringing this project to reality. PXE is an old yet very closed standard. You are pioneers.)



  • I got past the NFS-problem by changing the mount string! Thank you. :)



  • @george1421 said in NFS mount options needed.:

    But I can say many people (including myself) run FOG in a vm on vmware and I’ve never seen this issue.

    I do sys-admin for a living - me nether!



  • @george1421 said in NFS mount options needed.:

    To answer your question, yes you can change how the FOS engine mounts the fog server. You will need to unpack the inits (init.xz) and then edit the file /bin/fog.mount In there you shall find the mount command you seek. Once you update the fog.mount script then just repack the inits and move them back to /var/www/html/fog/service/ipxe directory.

    Here is how you edit the inits: https://wiki.fogproject.org/wiki/index.php?title=Modifying_the_Init_Image

    Great! Thanks!
    It’s 2 AM where I am, and I’ll give it a shot tomorrow and update on any progress. :)


  • Moderator

    @wombathuffer said in NFS mount options needed.:

    The only thing I am asking in this thread is - How do I specify NFS options when the PXE booted server is mounting the NFS-service?

    I was replying to your question just as you posted. See below

    But I can say many people (including myself) run FOG in a vm on vmware and I’ve never seen this issue.



  • @george1421 said in NFS mount options needed.:

    @wombathuffer In regards to the storage node, can we remove that from the equation? Power it off and you still have the same issue? I’ve seen some pretty creative uses of a NAS with fog. I just want to ensure you are not cross mounting the NAS onto the fog server and trying to reshare the mounted nfs share. Because that won’t work. As long as the NAS is a stand alone storage node then we are ok.

    So now I wonder what is unique about your setup where the standard nfs connect is failing? If you say its the same with virtual box and vmware. Understand I’m not poking at your issue, I’m trying to understand what might be different in your setup.

    Sure thing - I started off with no storage node, thinking the problem was on the NFS-service and not the VM.

    I have tested several times - problem is exactly the same when NFS-sharing locally from the FOG-server host…

    What is unique, is that I’m running the server in a VM.
    The NFS-problem is strictly non-related to FOG. Its deep down in the underlying VM-networking

    I was mistaken, when I troubleshooted the NFS-service in my post here:
    https://serverfault.com/questions/894881/mounting-nfs-server-running-in-vm-connection-timed-out

    The only thing I am asking in this thread is - How do I specify NFS options when the PXE booted server is mounting the NFS-service?


  • Moderator

    To answer your question, yes you can change how the FOS engine mounts the fog server. You will need to unpack the inits (init.xz) and then edit the file /bin/fog.mount In there you shall find the mount command you seek. Once you update the fog.mount script then just repack the inits and move them back to /var/www/html/fog/service/ipxe directory.

    Here is how you edit the inits: https://wiki.fogproject.org/wiki/index.php?title=Modifying_the_Init_Image


  • Moderator

    @wombathuffer In regards to the storage node, can we remove that from the equation? Power it off and you still have the same issue? I’ve seen some pretty creative uses of a NAS with fog. I just want to ensure you are not cross mounting the NAS onto the fog server and trying to reshare the mounted nfs share. Because that won’t work. As long as the NAS is a stand alone storage node then we are ok.

    So now I wonder what is unique about your setup where the standard nfs connect is failing? If you say its the same with virtual box and vmware. Understand I’m not poking at your issue, I’m trying to understand what might be different in your setup.



  • @george1421 said in NFS mount options needed.:

    how does your storage node factor into the nfs issue with the fog server?

    Not sure exactly what you mean? :)
    The storage node has a running (and working) NFS-server - thats about it.

    Main problem here, is the way the NFS client in FOG mounts the NFS shares. :)
    The FOG-server is running in a VM with weird networking hardcoded into VirtualBox/Windows (and problem seem to follow on VMWare as well)…

    Edit: In this case, it doesn’t matter if the images are store on a storage node or locally on the FOG-server. Problem is the same - when the PXE-booted host tries to mount the NFS-share, the connection times out anyway. Hope this was a fulfilling answer to your question? :)


  • Moderator

    how does your storage node factor into the nfs issue with the fog server?


 

374
Online

41.8k
Users

12.3k
Topics

116.0k
Posts