Estimated FOG sites: Error contacting server



  • Hello,

    This is my first ever FOG install (first ever experience with Linux aswell!), I am glad to say that the install has gone succesfully but there are a couple of odd little things cropping up.

    1. I have only tried to boot to the server via PXE once but that one time it did not work, it looked as if it was connecting to the server but then continued to boot into Windows…

    2. On the logon screen for FOG I get a message showing next to the two headings mentioning that there were errors contacting the server, not sure how to resolve this.

    3. If I changed/create a new user, it doesnt appear to push through to the database, I have created another account for myself and it has said that it has updated but when I try to login it just doesnt allow me to login.

    Currently running FOG v0.32 on Linux Ubuntu 10.4.4

    Any help would be greatly appreciated! it looks like an amazing program and I look forward to using it!

    Many thanks,

    Ollie Blake



  • You know what? ive been a complete numpty. I should have tested it before I asked for help.

    If I press a keystroke is aborts the automatic boot and I can select the options.

    Thank you so much for your help though regardless, youve got my FOG up, running and useable, your a legend.


  • Moderator

    Some devices I have require me to hit a special key during boot up to boot to the LAN, even if I set it in the BIOS. I also have some devices that have to have a certain key held down at boot up before it will boot to LAN. Most of these are small-form-factor, or tablet models that have specialized boards in them.



  • I dont get the chance to do that, it says “automatically selecting boot device in 1 second” then goes straight to Hard Drive.

    I have read that it could be something to do with chainloading, no idea what it means and the walkthrough looks a little out of my linux knowledge but I guess the only thing you can do is try!

    Any idea though aside from that?

    Thanks


  • Moderator

    You have to choose an option from the FOG menu… Full Registration and Inventory is probably what you need.



  • Looks as if that had resolved the issue, it now boots into the FOG menu, however, a few seconds after its been in the FOG boot menu it then exits out and continues to boot from the the local disk…

    Thanks so far for your help though, its greatly appreciated!


  • Moderator

    Log into your FOG web UI and set the timeout to 30 seconds. You may be bypassing the FOG boot menu due to monitor sync as the default timeout is like 3 seconds.



  • Yup, ive done that, still only gives me the option to boot from local disk, literally gives me a 3 second time window to select a different boot device. This is after it has found the IP address for the FOG server through DHCP aswell.

    Could it be that the pxelinux.0 file isnt being located correctly on my FOG server? possibly due to permissions?

    Thanks,


  • Moderator

    Check your boot file name/Option 67 value: it should be:

    pxelinux.0

    where the last character is a zero. Watch the client as it PXE boots. You should get a DHCP address, then some TFTP messages. If your DHCP server is in a different subnet than your clients, you will also need DHCP Relay/IP Helper settings on the layer 3 routers that handle your VLANs.

    As for the errors on the FOG Web login page, they are not critical, just informative. It’s a jQuery/AJAX call to the internet. Something is just blocking it, but it won’t buy you much to spend time getting it to work.



  • Hi chad-bisd,

    My apologies for taking so long to reply, I had only just remembered about the thread as I had to put FOG on the backburner unfortunately!

    1. I have currently set the DHCP to work through my Windows 2008 R2 server, set the DHCP scope entry 66 to the IP address of the server and entry 67 to “pxelinux.0”, it looks as if it does connect to the IP of the server, or at least finds it anyway, but it only gives you the option to boot to a local device…

    2. I have attached a file containing a screenshot of what I see what I access the FOG webgui, I have checked on the Ubuntu box and I can confirm that there the proxy is working correctly without and authentication, as it does around the entire school.

    3. I have tried on a couple of different browsers but without any success, could this be something to do with my browsers, after a cache clearing or could it be something to do with the server?

    Many thanks for your help with this, its greatly appreciated!

    Ollie Blake

    P.S Apologies, I have just noticed my other screen has been included in the screenshot.

    [url="/_imported_xf_attachments/0/168_Screenshot.jpg?:"]Screenshot.jpg[/url]


  • Moderator

    Welcome to FOG.

    1. How you PXE boot depends on your DHCP configuration. Are you using FOG to handle DHCP or do you have another server or appliance running DHCP?

    2. FOG tries to query the FOG website to get latest version and number of FOG installs using jquery. If you require proxy authentication or are in an isolated network (no internet) it will fail and you get the message on the login screen.

    3. You may be having a web cache issue logging in as other users. Have you tried restarting your browser?


Log in to reply
 

366
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.