Navigating to /fog/management shows directory contents?



  • Hi everyone, I’m having an issue with my FOG server. It’s running version 1.4.4 on Kubuntu. Whenever I try to access the management console, I only see the directory contents of the fog/management folder, like a service isn’t running. I’ve tried uninstalling and reinstalling FOG several times, and I keep running into this same error.

    Prior to this issue, I was running 1.4.4 successfully. When this issue with the management console started, I was able to reinstall v. 1.2.0 and everything worked–the management console loaded correctly. When I went to upgrade back to v. 1.4.4, however, the problem reappeared.

    I’m open to any suggestions at this point. Thanks for any help/advice!!


  • Developer

    @birvin Thanks for the update. Good to Herr it’s working now. Don’t think think it’s worth looking into this more as it seems to be a one time issue…



  • I checked the log files, and the only thing that stood out to me was “Failed to stop web services” when I tried to do the reinstall.

    I run the installer again a few minutes ago, and this time it went through with no problems. I can access the web GUI and everything is back to normal. I have no idea what I did differently!

    Do you still want to see the error logs?


  • Developer

    @birvin There are files missing in that directory (index.php and export.php). Something definitely went wrong on install. Please check the installer logs. You find those in the error_logs subdirectory which is created in the same directory where you ran the installfog.sh script.



  • It’s Kubuntu 17.04.

    alt text

    alt text


  • Senior Developer

    What version of Kubuntu is installed?

    What version of PHP is installed? php -v


  • Moderator

    @birvin It almost sounds like php is not installed on your system. Can you provide a screen shot of what you are seeing? That would give us a bit of context to the problem.


 

406
Online

41.6k
Users

12.1k
Topics

114.4k
Posts