FOG fails to reboot target computer after imaging



  • Hi everybody,
    we work in a high school in France and we also have somme difficulties with the new PC’s we installed recently. They are Lenovo Thincentre M710t with Windows7Pro64 installed on a m.2 SSD drives. We installed a new Fog server (the old one was a 1.2) : 1.4.4 on a debian 9-stretch server to deploy over about 40 hosts. This fog server is also the DHCP and TFTP server on an isolated network. We can make inventories, upload and download images (single and multicast) but the Fog server can’t reboot the hosts after these actions. The PC’s fall in a “dreaming state” : led power on, fan running but no boot for ever. The issue is the same as we boot in LEGACY MODE or in UEFI mode. The only way is to manually power down and then reboot after what the only fog service we installed (renaming hosts) works perfectly. We tried all the “Host Bios Exit Type” but without any success ! We also tried some of the advices in this post (scanfor, refind, …) with no results.
    The only time when the boot occurs is in case whe just make a network boot until the fog menu appears and then select boot to hard drive (first item) (or do nothing : then the boot occurs after timeout). We tried replacing the m.2 SSD with more “classical” drives HDD on SATA ports : the reboot by the fog server occurs normally and all is fine. So we suppose that the fog OS (bzimage, init.xz ???) is not able to send comprehensive command to boot the M.2 SSD drive but is OK with SATA drives… Is there anyone encountering a similar issue ? In this case, have a solution been tuned ? Thanks… J CANDAU (apologies for my nearly bad english)



  • @sebastian-roth Hi ! the initial kernel bzimage after fresh install was 4.11.0. I attempted to update from web interface but it was tricky because of rights on directories. Finally, I did it (command line via putty) but the pxe boot resulted in an error. I worked again on it and I succeeded : the current version is now 4.13.4 and all is working great ! I had to copy this new kernel in two places : /var/www/html/fog/service/ipxe and /var/www/fog/service/ipxe to overcome an error during the pxe boot process. That said, we configured another fog server for redundancy purpose and the upgrade from web interface 4.11.0 to 4.13.4 worked perfectly this time …(?) Thanks to every body for the reactivity. The Fog server is our very useful weekly tool to restore our classrooms… Best regards.


  • Developer

    @jeromecandau said in FOG fails to reboot target computer after imaging:

    I do not understand why the reboot is OK with a sata HDD and not with the M.2 one !

    This is strange indeed! Can you narrow it down to some specific kernel version within FOG? Have you tried different ones yet?

    Can you give Ubuntu Live DVD a try too? As well you might want to try the reboot=... kernel parameters.


  • Moderator

    @george1421 FOS reboot calls busybox. The current version of busy box I have on FOS on my flash drive is 1.26.2.


  • Moderator

    @jeromecandau I don’t know if I asked you this (sorry I’m in and out of too many threads), on your fog server, navigate to this directory
    /var/www/html/fog/service/ipxe In there, I want you to key in this command.
    file bzImage That will print out the version of the FOS kernel. What version is it?



  • @george1421 After flashing new bios version from Lenovo, nothing better else… I do not understand why the reboot is OK with a sata HDD and not with the M.2 one !



  • @sebastian-roth yes, with clonezilla CD and Gparted CD, last versions, all is OK…


  • Developer

    @jeromecandau Have you read through the other post yet? Try booting up a couple different Live Linux systems and see if those are able to reboot properly. Trying to gather more information here.



  • @george1421 tried with acpi=off : nothing better… I’m looking after bios updates.


  • Moderator

    I quickly scanned this thread and I didn’t see where I asked this question. Does this computer have the latest firmware installed? We have seen some pretty bad uefi firmware from this vendor, just saying…


  • Moderator

    @jeromecandau yes that is the location.

    Also thinking if the force doesn’t work then we can also try

    acpi=off Understand this is a unique issues, so we are making a new path here.



  • @george1421
    No success with this :
    0_1516803302396_bd6ceafd-e6ed-4cda-9b1c-337c8ef7e437-image.png . Is that what you meant ?



  • @sebastian-roth
    the SSD M.2 drive is connected to slot 9…
    0_1516803195001_52113582-9a9a-41da-867e-6746cbc8657e-image.png



  • @sebastian-roth
    Hi ! These desktop are Thinkcentre M710t from Lenovo with 16GB RAM (DDR4-2400 (1200 MHz) - Part Number M378A1K43BB2-CRC).
    The user manual is avalaible at :
    https://content.etilize.com/User-Manual/1038658110.pdf

    Motherboard : Manufacturer LENOVO Model 3102 (U3E1)
    Version SDK0L22692 WIN 3306006364178
    0_1516799369592_IMG_20180124_131445_a.jpg

    CPU Intel Core i3 6100
    Cores 2, Threads 4, Name Intel Core i3 6100
    Code Name Skylake, Package Socket 1151 LGA, Technology 14nm
    Specification Intel Core i3-6100 CPU @ 3.70GHz

    DISK : SSD m.2
    NVMe INTEL SSDPEKKF25 SCSI Disk Device
    Interface Unknown Capacity 238 GB
    0_1516799161804_IMG_20180124_131405.jpg
    0_1516799180925_IMG_20180124_131435.jpg

    This models come from central administration and will be numerous in high schools. Il would be great that we can use fog server as we did for a long time with no trouble… Anywhere, great thanks for developping a such usefull imaging server.


  • Moderator

    @jeromecandau For this specific host, can you add this kernel parameter?

    acpi=force

    For some reason I feel this is a flaw in the firmware and it was related to acpi. I do think we had this issue before. A quick google search found this: https://askubuntu.com/questions/764568/ubuntu-16-04-hangs-on-shutdown-restart


  • Developer

    @jeromecandau So I understand the taks (capture, deploy, …) run just fine and iPXE boot and booting the local OS from disk if no task is scheduled is fine too. But after tasks the machine does not properly reboot, right?!

    We need to know more about the exact hardware on which you have this issue. I do remember a lengthy discussion about an issue that sounds very similar to what you have. We still don’t really know what exactly causes the issue (mainboard, CPU, …?) but I guess it has to do with the CPU (Intel(R) Celeron(R) CPU N2820 in this case). Please check your CPU and read through this whole thread https://forums.fogproject.org/topic/10162/linux-kernel (from start to end!)



  • Yes, and I wonder why the Fog main OS (bzimage+init.xz) isn’t able to reboot the PC’s as the first iPXE boot menu is… Isn’t known the right reboot command by Fog since he can reboot ?


  • Moderator

    [Moderator Note] Hey, I’m a moderator I can fork topics if needed. ;-)
    This way the OP doesn’t have to retype his post I moved it to this thread.


  • Moderator

    @jeromecandau said in Problems with exit boot on M.2 SSD drive:

    The only time when the boot occurs is in case whe just make a network boot until the fog menu appears and then select boot to hard drive (first item) (or do nothing : then the boot occurs after timeout).

    OK lets start with the above. If this happens then you have the right exit mode in FOG. The exit mode values are only used in the FOG iPXE boot menu. When you start imaging, bzImage and init.xz are copied to the target computer then FOS (Fog Operating System, the customized LINUX that runs on the target computer for capturing and deploying images) starts. What is happening here after imaging (capture or deploy) FOS tells the computer to reboot then nothing… Do I understand that correctly?

    PS: You should probably start your own thread since your issues are different than the original poster. I don’t want to give mixed information in this thread.


 

407
Online

41.6k
Users

12.1k
Topics

114.4k
Posts