Live boot DLC and WinPE timing out or failing



  • Failing to get DLCboot ISO to boot through this method.

    I have tried with the iso in 2 locations: /ISO/DLCD/DLC.iso and /var/www/service/ipxe/DLCD/DLC.iso

    I keep getting similar errors. First I tried with these paramaters

    :DLCD
    initrd http://$192.168.25.66/var/www/fog/service/ipxe/DLCD/DLC.iso
    chain memdisk iso raw ||
    goto MENU

    And I got this error:

    0_1516125636532_fogfail2.PNG

    Then I tried with

    :DLCD
    initrd http://$192.168.25.66/var/www/fog/service/ipxe/DLCD/DLC.iso
    boot || echo failed to boot
    prompt
    goto MENU```

    and got this error

    0_1516125643668_fogfail.PNG

    I then tried removing the $ from the beginning of the IP address but it just takes me back to the FOG menu automatically

    Any help or suggestions on why this is timing out or what I am doing wrong would be greatly appreciated. Tearing my hair out with this one.

    Thanks



  • I have finally figured it out. The ISO’s won’t boot in UEFI mode and must be set to legacy (BIOS)
    For now everything is working. Thanks for the help guys.



  • @sebastian-roth I see. I suppose I’ll need to try dig in to this a lot more and figure out how to get this working. DLC boot is a diagnostics iso that I got from a colleague in work. It is similar to hirens with that it boots to a menu with mini windows environments, clonezilla, partitioning tools etc…

    I also have a custom Win10PE environment that I am going to try out and see if the results are any different. Should the ISO typically boot up as soon as it is done downloading the image to RAM?


  • Developer

    @dylz Not all ISOs boot like this. That’s just the way it is though I can’t actually explain the technical details of why it works with some ISOs and does not with others. It has to do with how the ISOs are build I am sure.

    That said, you can make pretty much any system/ISO boot by extracting the contents. But this is a very custom step. There is no general tutorial on how to do this as each ISO is a bit different. Maybe start by telling us what exactly DLC is and where you got this ISO from.



  • @george1421 Thanks for the advice that helped big time. But there’s still an issue. The ISO seems to download but nothing boots. I take it I need to replace “goto MENU” with a command that makes it boot the live cd now?


  • Moderator

    second issue is your path to the ISO image.

    /var/www/fog/service/ipxe/DLCD/DLC.iso is the linux file path since you are trying to access that iso over http you need this path:

    http://192.168.25.66/fog/service/ipxe/DLCD/DLC.iso


  • Moderator

    get rid of the extra “$” before 192 in your fog menu


 

323
Online

41.6k
Users

12.1k
Topics

114.4k
Posts