Another "Failed to set disk guid" for new HP zbook laptops



  • Sadly, I only have 1 machine to test with, so I don’t know if my fix for deployment would work when deploying to a different laptop. Running 1.4.4, originally installed 1.2.0 on this Ubuntu 16.04.3 LTS.

    Args passed: /dev/nvme0n1 /images/imagename/d1.original.uuids 1 /images/imagename
    

    file in question:

    /dev/nvme0n1 8889f7f0-8940-4616-b349-9f309c5469f4
    /dev/nvme0n1p1 1:CE8E-B3DD 1:affbfb07-c841-4f92-8f9a-fce300c11f29
     2:e4099b1d-e2fc-47a6-9365-e870d9595906
    /dev/nvme0n1p3 3:7AD65778D657339B 3:59ad939a-8328-4bde-adf0-fac606dd732b
    /dev/nvme0n1p4 4:10500599500586A6 4:24c1a96f-8c97-4e37-b0b4-91e6674319fe
    /dev/nvme0n1p5 5:608AD5528AD524F6 5:680b9a0b-1d5a-4898-876c-3bb69b42ef6f
    

    cat d1.partitions

    label: gpt
    label-id: 8889F7F0-8940-4616-B349-9F309C5469F4
    device: /dev/nvme0n1
    unit: sectors
    first-lba: 34
    last-lba: 500118158
    
    /dev/nvme0n1p1 : start=        2048, size=      737280, type=C12A7328-F81F-11D2-BA4B-00A0C93EC93B, uuid=AFFBFB07-C841-4F92-8F9A-FCE300C11F29, name="EFI system partition", attrs="GUID:63"
    /dev/nvme0n1p2 : start=      739328, size=      262144, type=E3C9E316-0B5C-4DB8-817D-F92DF00215AE, uuid=E4099B1D-E2FC-47A6-9365-E870D9595906, name="Microsoft reserved partition", attrs="GUID:63"
    /dev/nvme0n1p3 : start=     1001472, size=   461414400, type=EBD0A0A2-B9E5-4433-87C0-68B6B72699C7, uuid=59AD939A-8328-4BDE-ADF0-FAC606DD732B, name="Basic data partition"
    /dev/nvme0n1p4 : start=   462415872, size=     2007040, type=DE94BBA4-06D1-4D40-A16A-BFD50179D6AC, uuid=24C1A96F-8C97-4E37-B0B4-91E6674319FE, name="Basic data partition", attrs="RequiredPartition GUID:63"
    /dev/nvme0n1p5 : start=   464422912, size=    35684352, type=EBD0A0A2-B9E5-4433-87C0-68B6B72699C7, uuid=680B9A0B-1D5A-4898-876C-3BB69B42EF6F, name="Basic data partition", attrs="RequiredPartition"
    

    I renamed the d1.original.uuids file to something else and then my deployment task completed fine.

    In a few weeks, I’ll have another of these laptops to test with. Since right now it seems to be working at least, Tom, if you don’t want to do anything with this, just lemme know and I’ll mark as solved. Otherwise, let me know if there is anything else I can do to help.



  • @wayne-workman Everything still seems fine for this. Still can’t figure out how to mark as solved, but someone should do that if they can.



  • @wayne-workman I will do additional testing today and probably tomorrow then update this thread with results (i’m assuming that we’ll be good to mark solved at that point).



  • @szeraax If it’s fully healthy and working, I wouldn’t worry too much about it. Make sure everything works though. Like windows activation, reboots are smooth and fast, etc.



  • @wayne-workman The host is fully healthy after deployment, but I only have this one computer to test with for the next few weeks.



  • @szeraax said in Another “Failed to set disk guid” for new HP zbook laptops:

    So I should just assume that when I have 2 full labs of these getting deployed that that warning about not being able to set disk UUID is safe to ignore?

    I feel we should explore why it’s not working. You should explore if a host is fully ‘healthy’ after you deploy this image to it. Make sure the UUID thing isn’t breaking anything.



  • @Wayne-Workman Hmmm, looks like the d1.original.uuids file is the exact same as before and I still get this warning about being unable to set disk UUID.

    However, this time I let it run its course more and it still did allow the deployment to be removed from tasks page. I just was likely not patient enough during my last response.

    So I should just assume that when I have 2 full labs of these getting deployed that that warning about not being able to set disk UUID is safe to ignore?



  • @Wayne-Workman As an update, I am on dev branch. Tried deploying the image again and it this time said a “Warning” had been detected due to not being able to set the UUID. The task is not removed from the tasks page. I am now going to re-capture that image and deploy that to see if it works without issue. Will update in a little bit.



  • Will do.



  • @szeraax I think this was fixed in the dev branch. Try the latest release candidate and see if the problem goes away? Instructions on doing that are here: https://wiki.fogproject.org/wiki/index.php?title=Getting_FOG


 

319
Online

41.6k
Users

12.1k
Topics

114.4k
Posts