UNSOLVED Chainloading failed. DHCP is OK.

  • I am getting this “Chainloading” error. DHCP is OK. I am trying to capture a image to FOG Server.

    Can anyone help me?

    0_1514250451715_Chainloading failed FOG.png

  • Senior Developer

    @Marco-Antonio Is this still an issue?

  • @george1421 I have answered you in chat. I have tried one of the options, but it did not worked. I just don’t know what to do.

  • Moderator

    Well here is what I see. You have a dhcp server at and you have a dnsmasq server at, which is also your fog server.

    The is probably the vmware NAT dhcp server running on the NAT’d network. is providing a next server value that is confusing iPXE when it tries to load the fog iPXE boot menu.

    So how do you fix this?

    Well it depends on what your final configuration needs.

    1. You can stop the vmware dhcp server, stop dnsmasq, and run the isc-dhcp server on the fog server.
    2. Remove NAT. Depending on your final environment if its on a totally isolated network then just run isc-dhcp server on your fog server.
    3. Remove NAT and if your business network has a dhcp server, you can configure it to send the right pxe boot names to the target computer, or turn on dnsmasq to supply the pxe boot information.

    There are a number of things you can do to fix this setup. It helps to know what your needed configuration will be to choose the right options.

  • Moderator

    @marco-antonio Ah I see what might be going on, please look at the IM chat bubble in the fog forums tool tray.

  • Moderator

    @marco-antonio Ok let me take a peek at the pcap and see what it says. I may chat with you via FOG chat if I have many questions about what I see.

  • @george1421

    Link of pcap file: https://drive.google.com/open?id=1kOuDBFS33VqER4g65-7mvPjeY5Tmae72

    About NAT configuration, I have to say that i’ve tried set BRIDGE config (but I kept automatic (DHCP) IPs), in both VMS, but when I do it, I get “No DHCP or proxyDHCP offers were received” error.

    “Can you tell me what device is”

    • I don’t know. I gave it to you all the info that appeared in FOG terminal.


  • Moderator

    @marco-antonio That tutorial is pretty complete, and suprisingly contains current information for being written 2 years ago. There is some older information on dnsmasq but that can be fixed.

    So what do I see?
    NAT isn’t a good thing with FOG unless all hosts are behind the nat interface. If you need to interact with any system on the other side of the nat interface you will have no joy. Bridged mode is typically best when you are using VMs.

    FOG requires you to give the fog server a static IP address, you can do this with dhcp reservations if you MUST assign the fog server’s IP via dhcp, but static is always preferred. The target computer’s IP address MUST be assigned by dhcp to allow pxe booting to work.

    Can you tell me what device is If is your dns server and gateway, I might have suspected that should also your dhcp server. I have a feeling that something is giving out a bad next-server parameter.

    Thinking about it a bit more, maybe the shortest path to an answer would be to capture the pxe booting process and see who the actors are during the booting process. Will you follow these instructions and then upload the pcap to a google drive or dropbox and provide us with the link? https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    This will tell us exactly what device is part of your pxe booting process and what its telling the client.

  • @george1421 said in Chainloading failed. DHCP is OK.:

    Can you give us a better design layout of your network and confirm the IP addresses of your fog server, dhcp, server?

    Yes, i have dnsmasq in the config.

    Briefly, i have 2 Virtual Machines (Vmware):

    1. Ubuntu 16.04 LTS (Fog Server)
    2. Windows 10 (Client)

    The two virtual machines are configured as NAT.

    Ubuntu’s Ethernet network configuration it’s automatic (DHCP), as well the Windows Ethernet network configuration (DHCP).

    Server’s configs:

    Server IP:
    Installation Type: Normal Server
    Using FOG DHCP: No

    Client’s configs:

    DHCP active: Yes

    I had followed this tutorial to config the fog.

    Before this tutorial I was trying to configure DHCP (I was getting “No DHCP or proxyDHCP offers were received” error), and only after several hours I was able to find this tutorial, and although I am no longer with this error, I have this error of " chainloading ".

  • Moderator

    Well I see a few things.

    Your target computer is being assigned
    Your dhcp server is
    You have a proxy dhcp address of
    You have a gateway address of (a bit strange because your dhcp server is at .254 and you have a dhcp proxy server too).
    Your dhcp (next-server) is pointing to .131

    And finally your pxe client is trying to load default.ipxe from .254.

    I wonder why you have so many systems in the pxe booting process here?

    The .131 system makes me think you have dnsmasq in the mix.

    But .254 appears to be your dhcp server. Which makes me think your fog server may be at .254 address since it is supplying the dhcp address (running isc-dhcp) and its trying to boot from default.ipxe address.

    Can you give us a better design layout of your network and confirm the IP addresses of your fog server, dhcp, server?

    I can tell you that fog does not like to have its host system IP address changed after fog is installed. So if that is what happened here we need to resync things.