Deploying an Image Maxes Our Bandwidth. HELP!



  • We have a dedicated server and when we set up a deployment onto a machine, it’s EXTREMELY slow (80MB/min) AND it maxes out our network.

    Installed it on a Linux Mint 13 standalone server:
    Here are the settings FOG will use:
    Distro: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 10.52.1.69
    DHCP router Address:
    DHCP DNS Address:
    Interface: eth2
    Using FOG DHCP: 0
    Internationalization: 0

    We have a Windows 2008 R2 server running AD and DHCP. Please tell me I just missed an obvious setting. I’d really like to get this going. The FOG Logs aren’t showing any errors in the WebUI. I know it’s FOG that is causing the bandwidth spike… I just don’t understand why it’s trying to communicate with something outside our network.

    Any help would be appreciated! Thanks



  • djm79, I will try that and it IS using the internet for some reason (the client machine). I have a real-time bandwidth monitor and as soon as the deployment begins the graph spikes (pretty much triples) and begins using 21Mb/s with the client’s IP being the culprit. [B]I’ve only tried imaging from the same location (my office)[/B]. [B]Network misconfiguration? [/B]I’ll try at another location and/or hook the client & server directly to a switch and go from there.

    We’re calling the company we outsourced running the wires and installed the switches in the buildings to see if they would know of any reason before I get my hands dirty into uncharted territory.

    chad, I know! It’s killing me not knowing why this is happening pulls and handful of hair out.

    Thanks for all the help - I’ll report back with my solution as soon as I find out the problem. Thanks again guys.


  • Moderator

    Imaging a client (upload to server or download to client) should have no impact on your INTERNET bandwidth unless you are going over a VPN tunnel through your public interface or you have a misconfiguration in your network.

    FOG consists of TFTP during PXE, NFS mounts and transfers during upload and download, and FTP transfers between storage nodes. None of that goes out to get anything from the internet.



  • Is it all from the same location or all over your network?



  • Have you tried another client machine as a test? Can you run the imaging from the same switch that the FOG server is plugged into? I would start from there and work my way back to the switch you are using for the client computer. Also check on the switch that the client machine is plugged into that you are not having a duplexing problem IE its full duplex on both side meaning at the switch and the client computer.



  • Just more info:

    We’re unicasting.
    It happens with every model of computer we’ve tried (we’ve tried 4 different ones, 3 dells & an HP)



  • I ran the command and it seems that the machine that we’re deploying to was getting traffic to it at 8mb/s from the FOG Server. I was monitoring our network filter and it showed 100% bandwidth INTERNET traffic being used by the CLIENT computer (the computer we’re trying to image)… makes no sense. I’m stumped.



  • I have been tracking a problem similar to this. It ended up that one switch to the IT floor only had a 100 meg uplink where all the rest have 1 gig uplinks so when I swapped over to another switch boom 1.5 gig deploy speed and 1 gig uploads. I ended up jumping a gig port from our distro switch to our prep room where I setup a cheap D-link gig switch for our help desk to image machines. The Prep room is now getting 2.5 down and 1.5 up.

    I thought it was something with FOG. I original set FOG up in VMware and thought our new SAN was crapping out from the I/O from imaging. But I then set up a physical server and it was the same result. I started from the VMware rack plugging in and testing download speeds.

    You can down load iftop to the linux box and run it from the terminal and point it to your network interface and it will show you what its doing.

    run sudo apt-get install iftop from the terminal

    then sudo iftop -i eth2 it should output the current connections and the amount of the link that each is using.


Log in to reply
 

469
Online

38914
Users

10684
Topics

101325
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.