SOLVED Error 'Could not open inode 'XXXXXX" through the library'

  • Moderator

    @Jarl2-0 I thought I’d set up a test machine to replicate the issue but I am very short on time at the moment and therefore would ask you to create a metadata dump to send to the developer to look into. Quoting from his mail:

    I am interested in really fixing the issue, but I need to have a full picture of the metadata. This will not contain any user data, though the file names will be visible. Nevertheless this will be a big file which you will have to upload to a server for me to download (it will not fix in an email attachment).
    To extract the metadata image, do (as root) :
    ntfsclone -mst -O - /dev/xxx | gzip > metadata.gz (replace xxx by the partition name, like sda2)
    If you have a powerful computer, you will get better compression by using “xz -T0” (without the quotes) instead of gzip.
    This will require the partition to be consistent, you may have to do a chkdsk on Windows beforehand. If you cannot, you may add the extra option --ignore-fs-check but I might not be able to reproduce the issue.

    Please let me know if you need space to upload that metadata file somewhere but I guess you have google drive or dropbox or something like that. Please send me the link (in a private chat message if you like) and I will forward it to the developer. Thanks in advance.

  • Moderator

    @Jarl2-0 We got an answer! 🙂 Someone is interested to look into this, analyse metadata and try to fix the issue. But he also suggested to defrag the disk before doing the resize (capture)! Could be a workaround till we figure this out. Please give it a try and report back.

  • Moderator

    @sebastian-roth I have had the same issue on a Windows 7 installation (had been in use for maybe a year) which we had to clone as it was.

    Non-resizable worked fine, resizable failed with the inode message.

    edit: Sorry I can’t be more helpful than that, it was the only instance I could recall and of course I am not sure what they did on those computers.

    edit2: It could have been hardware related, they had been in use for a while, after all. (although SMART certainly didn’t complain). And of course did chkdsk /r and such with no change. (and no errors found)

  • Moderator

    @Jarl2-0 Thanks for the details. Sounds pretty straight forward. Though I still can’t imagine what exactly would break for ntfsresize. Unfortunately I haven’t got an answer from tucera yet.

    Is there anyone else out there who is able to replicate the issue as described here? @Testers @Moderators

  • @sebastian-roth

    It was after I removed the previous Windows version is when I had issues. I could take an image after upgrading to 1709 but when I went to clean out the previous windows version the next attempt to take an image would fail. I would say this happened about 4-5 times with different PCs (same model) before I pin pointed what step caused the image to fail.

    Steps for me were like this.

    1. Win10 machine with 1703 - Image Success
    2. Upgrade to 1709 - Image Success
    3. Remove old patch data - Image Success
    4. Remove previous Windows version - Image failed

    I removed the patch data and previous Windows install via Disk cleanup > Cleanup system files.

  • Moderator

    @Jarl2-0 Gosh, NTFS is a complex topic. I’ve tried reading up on this and figuring out what goes wrong in the code. No answers yet. But I see that we have more than enough reports by other users as well and you seem to kind of nail it down. So I hope we can figure this out together. I just sent an e-mail to as we use their latest ntfs-3g/ntfsprogs code compiled in the buildroot environment that we use for FOS. Keeping my fingers crossed that we get an answer from them.

    Yes I’m able to reproduce this. Clean install upgrade to 1709 test capture > Windows cleanup to remove old patch data and previous versions of the OS. The cleanup is done with windows disk cleanup.

    Can you please be more specific on how exactly you reproduced the issue? Does it happen on the clean install or after updating to 1709 or only after running the disk cleanup tool? How many times did you test this? Please don’t get me wrong, I am not saying this is not right. I just want to nail it down as much as possible to we can give tuxera people good instructions on how to reproduce this so they can go ahead and find/fix the issue in the code.

  • @sebastian-roth Yes I’m able to reproduce this. Clean install upgrade to 1709 test capture > Windows cleanup to remove old patch data and previous versions of the OS.

    The cleanup is done with windows disk cleanup.

    Another update is that I am able to take an update with the “Multiple Partition Image - Single Disk” image type. I would prefer Single Disk Re-sizable but it always failed.

    These settings are working for us to capture 1709 images.


  • Moderator

    @Jarl2-0 Thanks for updating this. Are you able to reproduce this issue? Like clean install, do all upgrades to the latest, test capture. Then do a cleanup and test capture again. Best if it could be done in a VM environment where you can use snapshots to go back to an older state.

    How is the cleanup done? Through the normal Windows disk cleanup or using third party tools?

  • I have some more info on this, it seems to only happen for me after I remove the old Windows versions from a PC I want to take an image of. A freshly updated PC to 1709 will have no issues until you try to cleanup those files. Which is annoying because they take up about 30gigs of space.

  • Went through and imaged a new laptop with a 1703 image was able to make some changes and take an image from 1703 just fine. Upgraded to 1709 and got the same inode error, something must have change I’m going to try to sysprep the image to see if that helps but sysprep has been failing for me on 1709 as well.

  • @sebastian-roth Tried your suggestions still having no luck, I’ll look at some of the other posts on the forums and see if I can find anything that works.

  • Moderator

    @Jarl2-0 We have had the issue posted in the forums a couple of times lately. Unfortunately we are not able to pin it down exactly. Possibly M$ has changed something with 1709 but on the other hand not all users see this issue. Quite often it can be fixed by disabling fast boot - which should be disabled on all machines anyway!

    I’d advise you to run a full chkdsk on Windows, maybe even defrag the disk and run chkdsk again. But this is just wild guessing.

    The Input/output error at the end of the message to me sounds like the filesystem inode is pointing to a sector that is beyond the disk. But I have no idea really.

  • I’ve confirmed that fast boot is disabled and I am still getting the error.

  • Moderator

    @Jarl2-0 Please make sure you have fast boot disabled before trying to capture that image. As well read through this wiki article: