virtualbox (version 5.2) vm not booting and showing arp timeout

  • I have in installed fog server on ubuntu 16.04 LTS and then make a virtual machine on virtualbox (version 5.2) on the the same machine with “Host only Adapter” networking between host and VM.
    i have installed dnsmasq (version 2.76)on the host ubuntu machine.
    Network configuration are as follows:

    Fog server ip address :
    Virtualbox Host network configuration are as follows:
    Host only Adapter (vboxnet0 —
    ip address of dhcp server :

    When I boot vm then i get the follwoing message:

    /etc/dnsmasq.d/ltsp.conf is as follows:


    /etc/dhcp/dhcpd.conf as follows:


    syslog are as follows:


    PLEASE suggest where is the problem. I have been stuck with the problem for the last one week. Plz help to get out of the problem.

  • @sebastian-roth

    thank you . I will open a new thread and You can mark it as closed.

  • Developer

    @vivek Is this image set to resizable or non-resizable? Was this setting changed between capture and restore?

    What disk size has your physical machine and what size has you VM disk?

    I’ll mark this solved as the initial question is being answered. Please open a new thread on further issues in the imaging process. It’s better to not mix up many questions in one thread!

  • @sebastian-roth

    "already created " means that with the help of fog server installed on the same ubuntu machine (on which I want to network boot virtualbox VM) I had captured Image of a physical machine (windows7 ) and now I want to deploy Windows7 image captured from the physical machine to the Virtualbox VM.

    When i deploy the image on network booted VM , i get the follwoing error:



  • Developer

    @vivek said in virtualbox (version 5.2) vm not booting and showing arp timeout:

    After booting from network I tried to deploy an windows image already created with FOG but it is showing following error:

    What do you mean by “already created”? Did you upload an image before deploying? Just creating it in the web UI is not enough.

  • @sebastian-roth

    Thanks a lot for ur suggestion.

    I could get the virtualbox vm network booted when i changed the network from "host only adapter " to “bridged”.

  • Developer

    @vivek Just looked at your pictures again. I kind of looks as if it properly points to and also sends undionly.kpxe as filename. Maybe your TFTP server is down? Run netstat -antup | grep ":69" as root on your machine and see what you get.

  • Developer

    @vivek Check this out:

    I haven’t used Host-Only much and therefore didn’t know that it does DHCP on it’s own. Not sure if it is possible to switch that off?!? If you can’t then I’d suggest switching off the normal isc-dhcp on your FOG server and installing dnsmasq there to be able to inject PXE information into the Host-Only DHCP information. That’s just an idea, haven’t tried this.

    Or you could just use a bridged network interface. I do that on my machine. For that I manually create a virtual tap interface (tunctl command) and use that as bridge device. It’s very similar to host only but I am in charge of IP address and weather it’s DHCP or static IPs.

  • @sebastian-roth
    Thank you very much for giving time to my problem.

    I have stopped dnsmasq then made the changes of next-server and filename in the dhcp conf file then restarted dhcp service.

    then i go the following error:

    I inspected the wireshark on vboxnet0 host only adapter interface of virutalbox:


    It is clear that i m still getting dhcp offer from two ip address 192.168.16 (fog server) and ( vboxnet0 interface ip address).

    I am not getting why is working as DHCP server.

    Please suggest the problem.

  • Developer

    @vivek Ahh, now I see. Should have asked earlier. I thought there was a good reason to use dnsmasq. For you to understand: To PXE boot a client you need to add two things to the DHCP information offered to a client. That is, DHCP option 66 - next server and DHCP option 67 filename. A normal DHCP server like you have with config file /etc/dhcp/dhcpd.conf is able to provide both those options (and many more) to the client. But there are other DHCP servers or situations where you can’t add those options. They just hand out IPs to clients but no PXE information. In such a case you can add dnsmasq to your network which can act as a so called proxy DHCP, as well answering clients’ DHCP requests but only providing PXE information (not IP address information). Clients are usually able to combine the two DHCP answers and do PXE boot. But it can be a little tricky.

    So as it doesn’t seem you need dnsmasq, we better try to get your dhcp conf right to set you up. Seems like you were just missing the filename option. So please add back the next-server; line which I asked you to remove and just below that add another line filename "undionly.kpxe";. Save config, restart service and you should be booting to the FOG PXE menu.

  • @sebastian-roth
    Earlier i was getting the following error:


    Then i searched on net and i got suggestion that dnsmasq would solve the issue so i installed dnsmasq.

    After your prompt i again stopped the dnsmasq then i again got the same screen mentioned above.

  • Developer

    @vivek said in virtualbox (version 5.2) vm not booting and showing arp timeout:

    i have installed dnsmasq (version 2.76)on the host ubuntu machine.

    I must have overlooked this! Why do you use dnsmasq at all when you could do it all with isc-dhcp-server?

  • @sebastian-roth
    i could not follow your instruction as command given by you “tcpdump -w /tmp/boot_issue.pcap arp” doesnt contain any x.x.x.x so i could not substitute it anywhere in command.

    i have captured packet with wireshark on vboxnet0 (ip - which is as follows:


    My fog server ip is and from the image it is clear that my machine didnt send ARP request to for server but it sent ARP request to ip address of vboxnet0 interface.

    my interfaces are as follows:

    student@student-PC:~$ ifconfig
    eno1 Link encap:Ethernet HWaddr a0:8c:fd:c0:4c:08
    inet addr: Bcast: Mask:
    inet6 addr: fe80::a28c:fdff:fec0:4c08/64 Scope:Link
    RX packets:163820 errors:0 dropped:0 overruns:0 frame:0
    TX packets:178255 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:127818705 (127.8 MB) TX bytes:90926652 (90.9 MB)
    Interrupt:16 Memory:d3100000-d3120000

    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:187367 errors:0 dropped:0 overruns:0 frame:0
    TX packets:187367 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:69347669 (69.3 MB) TX bytes:69347669 (69.3 MB)

    vboxnet0 Link encap:Ethernet HWaddr 0a:00:27:00:00:00
    inet addr: Bcast: Mask:
    inet6 addr: fe80::800:27ff:fe00:0/64 Scope:Link
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:232 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:30355 (30.3 KB)

  • Developer

    @vivek I think you need to do a packet capture to be sure about which address it tries to resolve via ARP when the timeout happens. So get your client ready but don’t start it yet. Go to your FOG server and install tcpdump (sudo apt-get install tcpdump). Then run the following command and substitute x.x.x.x with the client’s IP address: tcpdump -w /tmp/boot_issue.pcap arp
    Leave that command sitting there, boot up the client till it shows the error “ARP timeout". Now stop tcpdump (Ctrl+c). Upload the generated file /tmp/boot_issue.pcap to your dropbox/google drive and post a link here or send me a private message if you don’t want to share this with the rest of the world.

  • @sebastian-roth

    i have also searched on net about E11: arp timeout , then some people suggested that enabling of option 60 produces this error . In log file /var/log/syslog, which i posted in question, you can see option 60 is there . Can you tell me how to omit option 60 from the dhcp config file.

  • @sebastian-roth

    Thanks for your reply.

    As per your suggestion i removed the next server line form dhcpd conf file and restarted the dhcp server, still i m getting the arp timeout errror.

    Plz suggest another option

  • Developer

    @vivek From the configs you posted to me it looks as if you’re sending DHCP option 66 (next-server) twice - through dnsmasq and isc-dhcp-server. That might confuse the client. Remove or comment next-server ... line in /etc/dhcp/dhcpd.conf and restart the isc-dhcp-server service.