Unable to connect to TFTP server



  • Hello. Please forgive my ignorance. I am new to FOG. I took over as a net admin for a school district and was left with no transition from the old staff to get the computers ready for school in a couple weeks. I have been working on this for a couple days and would appreciate any help.

    First I am running fog .32 on Ubuntu
    I did not have any passwords to get into the fog system so i had to reset it using this method

    [url]http://www.fogproject.org/wiki/index.php?title=Reset_WebUI_FOG_password[/url]

    Then I went into the /var/www/fog/commons/config.php and changed the tftp password and the storage ftp password to the new one.

    Then i went into the fog settings and changed the tftp password there

    Then i went into the storage management -All storage nodes -defaultmember and changed the password there.

    I am still getting this unable to connect error. This is just one box in one building too. I have like 8 more. (bandwith issues is why all the boxes are local i think)

    Please help…Its for the kids!


  • Moderator

    For reference, the ONLY time you use FOGCrypt on a password is when setting the user credentials for joining computers to AD. All the other passwords in the FOG settings and config files are in plain text. I know some of them look encoded, but they are just random strings made complex enough so they are not easily guessed from 1 FOG install to the next.

    All you really needed to do what reset the password for the “fog” user in the WEB ui, which you can do through mysql command line if you can login to the fog server.

    You need to set the passwords in the /var/www/fog/commons/config.php and the web UI.
    [LIST=1]
    []open /var/www/fog/commons/config.php
    [
    ]set the TFTP_FTP_PASSWORD, doesn’t have to be complex, but write it down.
    []set the STORAGE_FTP_PASSWORD to the same value as TFTP_FTP_PASSWORD.
    [
    ]save the file.
    []from the command line: sudo passwd fog
    [
    ]Enter the same value you used for TFTP_FTP_PASSWORD and STORAGE_FTP_PASSWORD
    []open the FOG web UI.
    [
    ]login as user: fog
    []go to other information, FOG Settings
    [
    ]Go down to the TFTP Server section, make sure the FOG_TFTP_FTP_PASSWORD value matches the TFTP_FTP_PASSWORD value from step 2
    []Save changes
    [
    ]Schedule a task and see if it works.
    [/LIST]
    In FOG 0.32, some settings are duplicated between the config files and the database. So you have to make sure both spots are updated or you have weird problems. It’s getting cleaned up for the next version I think, but for now, change the values in both the web UI and the config files.



  • I did not. I am kind of out of ideas to try. This system is tricky if you don’t know what to do. I did find a box at another building I was able to get into and have been imaging the district off that box. It is killing my bandwith but it has been a fix in a pinch. I wish there was like a support team that I could call and just be like here control my box and show me whats wrong lol.



  • Hi Zach, did you resolve the error?



  • Yes I did use the fog crypt to generate a password. I changed my password to “password” then it generated a long encypted password that I unput everywhere it was needed. I am still getting the error.



  • This proccess change the password to enter in the webconfig but don’t change the password for de tfpd. Have you use FogCrypt.exe to generate the password por TFTPD and changed this password in FOG Options? You can download this file from [url]http://FOG_SERVER_IP/fog/client[/url].


Log in to reply
 

439
Online

38994
Users

10714
Topics

101705
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.