Reattempting to update database failed



  • Hi,

    My server : Debian 9
    Fog 1.4.4 6077

    Recently installed server.

    When capturing a folder is created

    0_1511461715814_pb_fog.png

    after the capture, i have this message :

    Reattempting to update Failed Error returned type 2
    File /var/www/html/fog/lib/fogftp.class.php
    ligne 463 ftp_login() : login incorrect host 10.130 …
    user name fog

    The station reboote and it starts again without ever ending
    I do not know what to do.
    Sorry for my english.
    Thanks.



  • @george1421

    Everything is working.
    Thank you very much.
    How to mark that the subject is solved ?



  • @george1421
    Thanks,
    I will test tomorrow because I’m not in my office.


  • Moderator

    @techno-clarensac Yes, you may NOT use the linux user fog for system administration. Please create another user such as fogadmin for system administration.

    To fix your install please do the following:

    1. Review the hidden file /opt/fog/.fogsettings
    2. Search of a line that has password= The text after the equals is what FOG thinks the password should be.
    3. Reset the linux password to the password identified in step 2.
    4. Go into the FOG Web GUI and into the FOG Settings and expand all entries, search for password there. Confirm that the password there is inline with the value you collected in step 2.
    5. Still in the Web GUI go into the storage node configuration for this server and confirm the password there also matches what you collected in step 2.
    6. Back in the linux console of the fog server, rerun the FOG installer to clean up the remaining bits and to resync the passwords.

    From there FOG should be happy.



  • To george1421

    For the session debian my login is : fog and password : password
    For the interface for my login is : for and password : password

    what should I change ?


  • Moderator

    OK what we usually see here is someone has change the linux user fog's password. This is not the default web gui administrator fog. I’m talking about the linux service account named fog created by the FOG installer. If you have changed this linux account, no joy for you. There is a way to fix, but first lets find out what was changed.


Log in to reply
 

453
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.