RTL 8111B - Not Booting PXE



  • Hello,

    I read and checked a lot, tried several efi files on USB, but Nothing is working.
    The bootable USB is correct on others PC.
    Only PCs with RLT 8111B are refusing to connect to the fog server.

    Has someone found a solution that could help me for this (old) card ? 50 PCs running on it :(

    Thank you in advance !

    Philippe


  • Developer

    @pcayphas said in RTL 8111B - Not Booting PXE:

    Only PCs with RLT 8111B are refusing to connect to the fog server.

    To take this a bit further and be really able to help you we need a more precise description or best photo/video of what you are running into. There are about ten to 15 different cases I know from the top of my head that would match your description. We need to be clear on what error/hang/issue you see!!

    Maybe there is something in this discussion that might help: http://www.edugeek.net/forums/o-s-deployment/39383-pxe-boot-realtek-8111b-c.html



  • Hello,

    I’ll perform the upgrade and will follow your advice.

    'l 'll come back later with the result.

    Thank you,

    Philippe


  • Moderator

    @pcayphas After you upgrade to at least FOG 1.4.4 (you really should since, you are on an RC (development) release of a fairly old release of FOG, we do have another method of USB booting (not using iPXE). Some UEFI firmware delivered with some computers have bugs in it that cause UEFI pxe booting to fail.

    You still haven’t mentioned what hardware you are having a problem with. Please post what manufacturer and model is not working.

    Here is the instructions to create a FOS usb bootable image. This process bypasses iPXE all together. There are some restrictions that I show in the post. So you must be aware of the restrictions when you use this USB key, but it does work. We have to use this method for OSX devices. https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image

    I’m only posting this link as a last chance solution. We really need to see why pxe booting is not working with your hardware.


  • Senior Developer

    @pcayphas I’d recommend upgrading to the latest RC’s, or even the latest stable version as 1.4.0-RC-12 is fairly old and many new features and bugs have been corrected since then. If you’re using plugins, in particular, 1.4.4 has a known issue where installing a new plugin, or reinstalling one, wont create the database table for that plugin if one was needed. There is a way to patch this which can be found relatively easily.

    As to the problem, I’m not sure what it is, or how much this Nic is causing issues when compared to the newer kernels. You could try updating your kernels to 4.13.4 and see if your Nic is working properly.



  • First of all, thank you for your answer !

    1. Running Version 1.4.0-RC-12 SVN Revision: 6069
    2. I tried a lot. I tried a bootable key with efi file from rom-o-matic following https://wiki.fogproject.org/wiki/index.php?title=USB_Bootable_Media procedure. USB Key was working on other coputers than RTL.
      I also tried to copy on the USB key in folder EFI/boot files (on test for each file) copied from the fog serveur (tftpboot dir) (I tried alsso the rtl*.efi files.
    3. My target computers can be UEFI or not. I juste want Something able to be compatible with my fog server
    4. As PXE Boot was not working at all, I tried the the usb boot method. But none is working.

    regard,

    Philippe


  • Moderator

    I can tell you realtek nics have been a pain in the back side of FOG.

    1. What version of FOG are you using?
    2. Are you booting into fog from usb stick? How are you doing this?
    3. You say your target computers are uefi, what computer and model is this?
    4. Are you trying to pxe boot at all or are you using usb booting method?

Log in to reply
 

455
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.