SOLVED using kerberos - Setting up fog password failed!

  • Hi,
    i’m using debian with Kerberos. Setting up the password for user fog fails. The reason is line 1045 in lib/common/

    echo -e "$password\n$password" | passwd $username >>$workingdir/error_logs/fog_error_${version}.log 2>&1

    If i try to change the password for a user in the terminal i will be prompt for the current password:

    ...$ sudo passwd fog
    Current Kerberos password:

    After this i can enter the new password.

    Any idea, how to avoid this?

  • i try a virtual machine …

  • @lebowski said in using kerberos - Setting up fog password failed!:

    I try to integrate it onto an existing server.

    That’s a really bad idea and will only cause you problems. FOG wants it’s own OS, and doesn’t play nice with other software. You’ve likely broken things that were already on the box simply by trying to install FOG onto it.

  • I try to integrate it onto an existing server. So Kerberos is still runing.
    It seems to wirk, if i uncomment the line. After installation i set ther passwd using the Kerberos admin console and the passwort from /var/www/fog/lib/fog/config.class.php

  • While I understand what you’re doing, I don’t know that this is a feasible element to incorporate into the server elements of fog. Not because it couldn’t be done, but rather what the fog user represents for the server. The fog user should be a local account to the machine similar to the root user.

  • @lebowski What’s the actual error?