peculiar search results in the host search



  • As you can see in the photo, the search for a specific string yields a variety of results that I do not understand. Is there a reason for that?
    ![0_1510749655967_fog_searchresults.jpg](Uploading 100%)



  • I think the hostname policy of our company is the problem. We use year numbers and consecutive numbering as names for the hosts. And exactly in the query with one of the consecutive numbers results in several results of the query. Just there.
    If I enter the entire name, it will only display that one host.
    The case can be marked as solved.
    Thank you for your cooperation.


  • Developer

    @Deimos I’d suggest backup up the whole DB to a database dump and taking a look at the raw data to see what could be causing what you see when searching for host.

    So far we haven’t heard from other people having such an issue. I tend to mark this solved as I hear back from you.



  • The “problem” still exists. As far as I can tell, I have examined all possibilities. But e.g. if the timestamp is converted from milliseconds to YYYY-MM-DD hh: mm: ss or something, then that´s just the way it is.

    It is not a real problem, the search results are clear and not so many, I always find the right host.

    I think there is data that compares with my query (it´s always a number like 1234) and I can´t find it in the Web GUI output. e.g. I can´t figure out product key.


  • Developer

    @deimos Have you figured out what was going on with this? Have you had a look at “Host description”, “Product key”, inventory data…?

    Especially as the number I enter, depending on which, always different hosts are displayed. I can´t make head or tail of it.

    What exactly did you mean by that? Can you explain in detail.



  • I understand that quite well. But the results do not make sense. The hosts are all the same devices. There are a total of about 500 computers. They only differ in name, mac, serial numbers and maybe in different first imaging date. So I checked the searching string in the serial numbers but no match at all. I searched meticulously and found nothing.

    There is no other match in this string but the name (and for this I was searching for). Especially as the number I enter, depending on which, always different hosts are displayed. I can´t make head or tail of it.


  • Senior Developer

    It searches multiple things for the string you’re searching for. Such as:

    Serial, Product, Description, hostname, image name, group name, etc…



  • 0_1510749940265_fog_searchresults.jpg


Log in to reply
 

436
Online

39.9k
Users

11.2k
Topics

106.9k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.