Dell Poweredge R330 with PERC S130 Raid Controller

  • Running Version 69
    SVN Revision: 6079

    Looking for a little help with capturing/deploying an image on a Dell R330 with a PERC s130 RAID controller. I am thinking maybe its a driver issue for the RAID controller. The configuration is RAID1 and when the image is captured the only partition that is seen is /dev/sda1. However there should be multiple partitions on the image. When deployed, the RAID is broken on /dev/sda and will not boot, so it defaults to the RAIDed disk /dev/sdb and boots to that (which is unimaged, so its the original OOBE os). We have imaged other Poweredge machines with PERC RAID controllers and they have worked fine. However, the two machines I have tried with the s130 have both failed.

    Any help would be appreciated! Thanks

  • Moderator

    @fallingwax FWIW, I just checked at the H330 is $155 more than the S130. For a moment I thought they removed everything but the S130, but you need to select the hot plug drive trays before the H330 is an option. I know it was there because I purchased a R330 in July and linux is installed on that box right now, so know I didn’t pick a S130. But anyway, I hope you are able to turn on that option in the firmware. It looks like the S130 is using the intel software raid controllers, so you may have some luck with madm.

  • @george1421 Understood, I didn’t read that document thoroughly enough. I will recommend to our purchasing department to look at the hardware raid controllers. I am sure its a cost decision but more likely its that they don’t know any better. Thanks!

  • Moderator

    @fallingwax Again its not a FOG or Linux issue. Its a “owners issue” for purchasing the S130 or any other SXXX dell raid controller. Those are windows only raid controllers.
    While this is a moot point now, when I spec out servers I only spec the HXXX controllers so I don’t have to worry about what OS will run on it.

    Back on point, the pdf I linked to said for linux support you need to enable a function that is disabled by default in your firmware (it wasn’t clear if this setting was in your raid controllers firmware or your server firmware. I didn’t read the user manual for the S130 like the PDF recommended.

    Then from what I gather you can use madm to manage those arrays. Just like with the intel raid controllers. At least that is what I gathered from that pdf.

  • @george1421 Any chance we might see support for this in the future then? Would save me a lot of time!

  • Moderator

    Whelp, I may have to eat my “fake raid” words.
    [Edit] Well after fully reading the article I might just have to nibble around the edges of my words. But it still look like there is hope as long as the caveats are followed [/edit]

  • @george1421 Or design the raid in a software layout Linux would understand, but then I don’t think Windows would be able to see the RAID. Double Edged Sword I supposed?

  • Moderator

    @fallingwax Then I’m afraid you are out of luck. Linux is seeing those disks as JBOD and not an array. I was hoping that by setting the kernel flag and using madm you might be lucky like with the intel fake raid.
    Unless you can find a S130 linux driver you might be out of luck imaging with FOG (or any other linux based cloning tool i.e. clonezilla).

  • @george1421 said in Dell Poweredge R330 with PERC S130 Raid Controller:

    I looked at that guide and got into debug with mdraid=true on. looking at /proc/mdstat, there is no md126 present or anything else there for that matter. The drives that show up are /dev/sda and /dev/sdb/ .

  • Moderator

    [snark on] You need a bit more than a little help capturing through that S130 raid controller. That is a windows only “fake” raid controller. [snark off]

    Its not a FOG issue, but rather a Linux issue, where LSI won’t release the driver code for those types of drivers. So no linux drivers exist yet.

    With that said, you might want to have a look at this tutorial to see if mdraid can make use of that array.