Solved: Fog client cannot authenticate on CentOS 7.4



  • Hello,

    Since I spent quite some time analyzing, testing and finding the solution to this problem, I think I should share with the community what I found.

    So following the Fog client Installation guide over here, I ended up with a client that was not working at all.

    The same problem was observed on ubuntu by someone else, but the solution there was not working for me. See: Linux client could not authenticate

    From the different forums entries, I could put together that the problem seems to be with the way mono handles the keystore. The most recent version of mono cannot fetch its own certificates in its keystore for some reason.

    The solution is not to simply reinstall the same version of mono + smartinstaller.exe as suggested everywhere, but to install an older version of mono. I personally chose version 3.12.1-0, following the success someone else had with a similar problem in the forums. Other mono versions could be tested with success as well I guess.

    So here are the code snippets:

    First we need to uninstall mono and smartinstaller.exe:

    sudo mono smartinstaller.exe uninstall
    cd /etc/yum.repos.d/
    sudo rm download.mono*
    sudo yum remove mono-complete
    sudo yum autoremove

    To install an older version of mono with yum, it’s tricky because of depedency problems showing up all over the place. This is what worked out for me:

    sudo yum-config-manager --add-repo http://download.mono-project.com/repo/centos7/
    sudo yum --setopt=obsoletes=0 install mono-complete-3.12.1-0
    sudo mono smartinstaller.exe

    The “–setopt=obsoletes=0” was critical to install the depedency packages properly. Yum would just not want to install some packages for some reason without it.

    You can find all the older mono versions available from the repo with the following command:

    sudo yum --show-duplicates list mono-complete

    So this little procedure solved my problems, I tested that I could schedule a reboot from the fog web gui through the client. The fog.log showed the connections were finally successful, although only one sync cycle out of two. Still, it seems sufficent for proper operation.

    Hope it helps someone!


  • Developer

    @fredlenomade Looking great! Thanks heaps for the detailed explanation on this. The mono keystore is quite a problem on some systems. So it’s great to have this manual on how to make it work in CentOS!


Log in to reply
 

427
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.