Unable to view host list after upgrade to 1.5.0-RC-9



  • Fog running on Ubuntu server 16. Web interface was down so the first thing I tried was to update to the latest FOG version. Interface is back up and working fine except for the fact that my host list isn’t there. Originally I though I’d just need to import from a backup again but when I manually tried to enter a host it told me that I already had one with the same machine name. So it seems like the hosts are there but I can’t get them to display. Tried 3 different browser and got the same result. The search options appear for a split second and then the screen changes to look like this:
    0_1510084330996_MQAFOG error.PNG

    I should note that the image section is working normally and displays my uploaded images normally.

    Any idea what I can do to get my hosts to appear again?



  • Same problem for me

    Debian 8
    1.5.0 RC10

    If i search a host i can find it and deploy image.

    But when i try list all host i have a message for 2 seconds “No result Found” and the same screen of the first post.


  • Senior Developer

    http://fogserver/fog/management/index.php?node=host&sub=list

    This direct link shows the same thing? (change fogserver with your hostname/ip for the fog server itself.



  • @sebastian-roth I’m having the same issue as @jglessner
    running Ubuntu 14.04. Noticed issue in 1.5.0-RC-8, upgraded to 1.5.0-RC-10, same issue. When I click on list all hosts, “No results found” breifly appears, then it flips back to screen @jglessner posted at the top of this thread. If I enter a PC name in the search field in top left, my PC is there. If I search for a partial name my PC’s are there, but list all PC’s is blank. I changed FOG Configuration -> FOG Settings -> FOG View Settings -> to ‘Search’, no change, back to ‘list’, no change



  • @sebastian-roth
    Thank you for your detailed response. Sorry for my delay in getting back to you.

    I followed your instructions for listing the hosts and host MACs. It looks like all the data was actually still there.
    193 hosts
    251 host MACs

    I removed the hosts and MACs anyway since I have a pretty recent exported host list. After removing them I returned to the web interface and saw that there was one pending host listed on the host management screen. This was the first time since updating that I’ve had any host information appear here.

    So with the hosts and host MACs all removed, client machines are trying to register and successfully appearing as pending hosts.

    I imported my host csv and successfully imported 189 hosts, however as soon as the import was done the host list appeared blank again just like in my previous snapshot.

    Is my host data itself causing the issue?

    I looked at the CSV and the entries are pretty varied. Perhaps I should clean it up more before uploading?

    I don’t have a problem sharing it through a private message if you would like.


  • Developer

    @jglessner So it seems like all your hosts are gone (mysql table hosts) but the associated MAC addresses (mysql table hostMAC) are still in the table. I think we need to look things up directly in your DB. First take a look at the file /var/www/fog/lib/fog/config.class.php to find your mysql user and password. Then connect to the DB and run queries like that:

    shell> mysql -u root -p
    Enter password:
    ...
    mysql> use fog;
    ...
    mysql> SELECT hostID,hostName FROM hosts;
    ...
    mysql> SELECT hmID,hmHostID,hmMAC FROM hostMAC;
    ...
    mysql> SELECT COUNT(hostID) FROM hosts;
    ...
    mysql> SELECT COUNT(hmID) FROM hostMAC;
    ...
    mysql> exit
    shell>
    

    You seem to have plenty of hosts so I can understand if you don’t want to post the full list here. But let us know how many entries were counted in each table. My guess would be zero for hosts and roughly 200 for hostMAC.

    You seem to have a recent host list exported so we can correct this by purging all the entries from the DB before importing the CSV again. Please be very careful to not drop entries from other tables. I am not liable for any data being lost!

    shell> mysql -u root -p
    Enter password:
    ...
    mysql> use fog;
    ...
    mysql> DELETE FROM hosts;
    ...
    mysql> DELETE FROM hostMAC;
    ...
    mysql> exit
    shell>
    


  • @tom-elliott
    Updated to RC-10 still experiencing the same issue.
    I tried exporting the host list and the generated csv is blank. Also tried to import my most recent host list for this site and got the following message:
    0_1510232675882_no hosts MQAGSFOG.PNG
    So it still seems that the hosts are in there somewhere but are not being displayed.

    Maybe a permissions issue? Maybe I could remove the host information from the server side and try to re-import?

    I’m a novice Linux user so I could use some direction in finding the files if you think that is a good idea.


  • Senior Developer

    can you try updating to RC-10. I seem to vaguely recall a problem like this and am fairly sure it has been fixed.



  • If only it were that simple. I should have been more clear in my first post. The screenshot is what I see when I click on “List All Hosts”. I changed the FOG View Settings to display the list of hosts and the hosts default screen is the same as in the attach image still…



  • This post is deleted!

  • Developer

    @jglessner Just click “List All Hosts” from the left menu to see all your hosts! This is something you might need to get used to in the new UI style. You can also change the default behavior to show a list instead of the search in FOG Configuration -> FOG Settings -> FOG View Settings -> VIEW DEFAULT SCREEN.


Log in to reply
 

427
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.