Disable DHCP Server



  • I have installed Fog32 on Ubuntu 12.04, during install I specified Yes to use the Fog server for DHCP Services. Since then I have decided that I want to give the proxyDHCP setup (http://www.fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server) a try.

    I am a novice when it comes to Linux can someone tell me what I need to do to disable the existing DHCP setup on my fog server, rather than having to reinstall everything from scratch



  • Chad’s instructions for checking the package name and for removal both worked great. We are extending power from a box that’s on our generator to the phone switch room and adding a UPS for the phone switches, so we will be able to verify the DHCP issue has been resolved shortly. Thank you for posting up those commands.



  • Which solution worked best for the original poster? I am in a similar situation where I discovered that my “Yes” selection for DHCP has caused a conflict in my existing network and I need to change the setting. The issue actually went unnoticed until we had a power failure and our IP phones were not coming back up with the correct date and time. Finally figured out that the FOG server was the culprit since it was happening only to certain subnet phones. I will try the above suggestion for checking the version as I am running and older flavor of Ubuntu Server and I will toss a Like if I can still PXE and all that fun stuff ater removing it.


  • Moderator

    Just remove the dhcpd using apt-get remove.

    You can use “dpkg --get-selections | grep dhcp” to get the exact package name. I believe it’s “dhcp3-server”, so “sudo apt-get remove dhcp3-server” should get it.



  • have you tried pxe booting a client yet? A good test is to try update the kernel. I was absolutely unable to do this on 12.04 and 0.32 (see my post, I thought it was as easy as changing the passwords and restart tftpd-hpa, but no) I would make sure your fog setup is working correctly before changing the dhcp settings.

    I think you have several options. (i’m pretty noob too)

    delete the .fogsettings (use ls -a to find it in your root fog directory) file and rerun ./installfog.sh without fog dhcp (not sure if this modifies the dhcp if it’s already setup but worth a shot)

    reconfigure the dhcp.conf file manually.

    I can’t remember what dhcp 12.04 uses. isc-dhcp-server or dhcp3-server

    have a look in /etc there should be a dhcp3 folder. You would need to edit the dhcp.conf file for proxy. In fact I think fog backs up your dhcp.conf. have a look for dhcp.conf.fogbackup and reinstate this file.


Log in to reply
 

433
Online

38920
Users

10689
Topics

101411
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.