Solved: Task is "complete" within seconds (Problem with GPT/MBR)



  • Hi everyone

    I solved a problem with fog and want to share it. I needed some time and hope someone else can save that time.

    [B]problem description[/B]
    [LIST]
    []Start uploading an image (Windows 7 on a Fujitsu Siemens Celsius W410)
    [
    ]It comes to the normal routine just before the screen with the blue background and the copying of “/dev/sda”
    []Instead it says: “Task complete” and fog ends.
    [
    ]The web interface means the task is finished. There is no Active Task
    []On the share, just the file with the MBR (d1.mbr) is present
    [
    ]No image, no cloning
    [/LIST]
    [B]researching[/B]
    I’ve found the hint to look at the Partition Information.
    At the FOG-PXE-Start-Screen chose: Client System Information wählen -> Partition Information
    It says something about GPT ([url]http://de.wikipedia.org/wiki/GUID_Partition_Table[/url]). GPT replaces the MBR. Its relevant when the computer has UEFI (replacement of BIOS). I had this problem just on the newest computer in our school.
    Removing the GPT information will solve it.

    [B]solution[/B]
    [LIST=1]
    [][B]IMPORTANT: First of all create a backup of your harddisk because the following commands are risky. Copy it one-by-one with Acronis, Ghost or other tools to another Harddrive.[/B]
    [
    ]The software is called “fixparts”: [url]http://www.rodsbooks.com/fixparts/[/url] -> I reccomend to read this page. Otherwise you don’t know, what you are doing exactly and what the risks are.
    []Download systemrescueCD ([url]http://www.sysresccd.org/Download[/url]) burn it on a DVD or create a bootable USB-Stick
    [
    ]Unfortunately the command “sfdisk -d /dev/sdc > parts.txt” didn’t work. It means the MBR isn’t backuped. But I had a backup of the whole harddisk. So it’s no that dangerous
    []type in: [I]fixparts /dev/sda[/I]
    [
    ]confirm the following message with “yes” if you really want it. -> Did you create a Backup? :-)
    [/LIST]
    [INDENT=2][I]FixParts 0.8.5[/I]

    [I]Loading MBR data from /dev/sda[/I]

    [I]NOTICE: GPT signatures detected on the disk, but no 0xEE protective partition![/I]
    [I]The GPT signatures are probably left over from a previous partition table.[/I]
    [I]Do you want to delete them (if you answer ‘Y’, this will happen[/I]
    [I]immediately)? (Y/N): y[/I]
    [I]Erasing GPT data![/I][/INDENT]

    Now restart your computer and check if windows starts. When everything is right retry uploading an image.

    I hope this information helps someone in the world wide “cloud”. ;-)

    Greetings from Switzerland
    Michael



  • This is good info, Michael. I appreciate it when some people do the extra research that is needed to identify the cause of problems.

    Let’s hope this will lead to better partition table handling in FOG, so that FOG can handle GPT as well as MBR. I believe this is one of the major shortcomings of FOG these days.

    Bjorn



  • Hi madeyem

    Cool. It’s great if this solution works for you as well. :-)

    Michael



  • Thanks Michael!
    This is also the solution to my problem described here:

    [url]http://fogproject.org/forum/threads/win-7-image-upload-no-partitions-found.1130/[/url]


Log in to reply
 

460
Online

38968
Users

10709
Topics

101631
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.