Fog, Router DHCP and PXE now not working



  • Ok guys, after hours and hours and reading and reading I had my Fog server running great. Then we had a power outage (UPS protected) then my Fog server/router went down. Problem is, everything was working great. Now for some mysterious reason, when I boot from PXE, I get no DHCP address from the router. Not sure if this is a dhcpd.conf file I need to adjust but basically here’s my setup.

    192.168.1.1 (router address and DNS pointer)
    192.168.1.2 (fog server itself and tftp server)

    DHCP and PXE worked great and was working - not after several FOG server reboots, I get no dhcp handouts.

    Ugg!


  • Developer

    I set up DNSMasq when I work at home with home networking equipment. a lot of the home issued stuff won’t have settings to be able to designated the tftp/boot server or the next-server. Using a DHCP proxy service like dnsmasq has prooved beneficial.

    Something else I have done is turn the DNS portion of FOG on and use a hub and keep it separate from the network unless an internet connection is required, which I have not needed DURING imaging, only after.



  • If you’re router is already doing the DHCP part, you need to be able to tell it where to find the TFTP server, so that will depend on the brand and OS on the router.



  • Anyone have settings for FOG on a home network, where my router is already doing DNS/DHCP?



  • Do you have other DHCP Servers in your network?



  • Thank you Eclat2k, Thank you sooo much!
    I believe I do have the same problem. I am posting my dhcpd.conf information below. I’m not sure of the exact way I should type in the the interface eth0
    Can you please help me edit? I will also do a search to see if I can figure out the proper way to enter it. The sample listed here is missing.

    DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 192.168.10.195;

    subnet 192.168.10.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 192.168.10.10 192.168.10.254;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 192.168.10.5;
    option routers 192.168.10.1;
    filename “pxelinux.0”;
    }



  • Hi ErinS, dhcpd.conf is in /etc/dhcp (in Ubuntu 12 and 11). When modify this file, restart the service to apply the changes.



  • Hi Leroy,
    I’m having the same problem as you did. I can not PXE boot anymore. I can’t find the dhcpd.conf file you mentioned. And I wonder about exactly what folders are suppose to be where.
    For example in FOG, other information, the TF TP Server information states tht the FOG_PXE_BOOT_IMAGE is located at fog/images/init.gz but I do not see a fog folder at the root.
    Could we share some screen shots or something. I’ve been at this for four solid days.
    Thanks!



  • OK, unrelated to here, but I found the fix.

    For some reason (Ubuntu 12.04) after a reboot dumped the interface eth0; entry in the dhcpd.conf file, after netmask. Edit, update, restarted dhcpd.

    Working.


Log in to reply
 

443
Online

38994
Users

10714
Topics

101704
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.