PXE: No boot filename received



  • Hello, this is your absentminded friend again.

    So,
    ThinkstationBIOS, disabled OS optimized, Boot mode auto, FOGScheduled Task, ThinkstationRestart:

    MAC: GUID:
    DHCP…/
    PXE - No boot filename received
    Boot to win 10, can reach fog.


  • Moderator

    @jackiejack No one will get angry. We all were “new” at one time. You are learning what you can and can’t do. FOG is a really complex system with several other open source systems under the hood. Its not something you can pick up and run with on day one. The developers have done a great job of hiding the complexities inside fog with the nice web ui.



  • @george1421 Will ask my superior about dns masq. But, as I am very new on the job I will stick to usb for the meanwhile. It is cloning now. I hope you all won’t get angry with me and my stupidity. Learning everyday. Will get there soon.


  • Moderator

    @jackiejack Sorry I meant to include that in my last page of text. Yes dhcp is a requirement for PXE booting. Because the pxe boot client doesn’t know anything. It needs dhcp to supply it with the information it needs to boot. Without dhcp pxe booting isn’t really possible (it technically IS possible to do but it means creating your own boot roms which isn’t practical in most cases).



  • Thank you for bearing with me. You need dhcp for pxe boot.


  • Moderator

    @jackiejack I’m not sure I understand your request.

    Your overbosses say you can not alter dhcp server to support pxe booting. You also had constraints (if I remember correctly) they didn’t want accidental imaging to occur.

    If they are willing to allow network booting for imaging but still do no want to change dhcp server then you have an option to have FOG supply pxe booting information as long as the target computer is on the same IP subnet as the FOG server. You would do this by using dnsmasq service on the FOG server. Again you don’t change master dhcp server only supply what is missing needed for PXE booting.

    We went with the USB booting method to satisfy the original constrains of 1. not changing dhcp server. 2. no unintentional imaging of target computers. With the USB booting you can’t accidentally image a machine because you have to physically go to that machine and insert the USB boot drive.

    If I’ve missed something let me know and we can change design. Right now only USB booting is possible because of your constraints.



  • @george1421 So no pxe boot for me then?


  • Moderator

    @george1421 If you are getting errors, please take a clear picture of the error with a mobile phone and post it here so we can see the context of the error to better understand it.


  • Moderator

    @jackiejack Correct the USB is providing what you would get through PXE. Once the computer is registered then you go into fog web ui and configure the system, assign to an image and then schedule a capture or deploy task in web ui. Once the task has been scheduled then you usb boot the target computer and pick option 1 to capture/deploy.

    Without PXE booting you loose the tight integration between target computer booting and imaging, but as long as you follow the sequence above then its all right.



  • @george1421 I use usb to register host. Then, the registered host can boot from FOG server? It’s already registered so no need to go though DHCP?


  • Moderator

    @jackiejack See this is where I’m getting confused. If you are booting from usb boot drive, at no time do you use pxe or any pxe information. The “PXE - No boot filename received” is typically seen when booting from the network.



  • @george1421 Remember I couldn’t forward dhcp ports. Company policy. So I boot up from usb and registered the host. I am of the understanding that the as the computer PXE boots, it will ask “Is there a server with an os I can boot from?”

    Then FOG will say here, look me!

    Then, host gets os, then ip address from the dhcp server. So FOG server will need to provide boot file, directly. Am I right?

    (Take your time)
    EDIT: as a matter of fact, only when I schedule a capture task, does the host give this error.


  • Moderator

    @jackiejack Ok (toooooo many thread, so little brain cells that remain functional), then you need to find out why your dhcp server isn’t providing a boot file name (dhcp option 67) while pxe booting.



  • @george1421 no no dnsmasq. You helped me with USB FOS boot device. Registered host no probs.
    back in 10


  • Moderator

    So if I remember correctly, your main dhcp server can’t be altered. So you setup dnsmasq to supply the dhcp information to your pxe booting clients. The error message seems to indicate that your dnsmasq service is not running on your FOG server. You might want to check into why that service is not responding to the dhcp request.


Log in to reply
 

522
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.