Dell Precision T3620 with NVMe



  • Used FOG religiously at my old IT position, got a new job at a new company and am trying to implement FOG here. I came from a company that only bought Dell OptiPlex’s with spinning disk drives, to this company where everyone has a Precision tower and they started ordering them with NVMe SSDs a few months ago. When running the initial inventory to register the computer, it would error out when trying to detect the hard drive and reboot after 1 minute. I’m on the latest version of FOG (as of 09/13/17, 1.5.0-RC-9 revision 6080) with the latest kernel (4.12.3). Is there some workaround for this? I’ve exhausted Google for a fix, and have kind of given up.

    BIOS settings are:
    Secure Boot: off
    PXE Boot: on
    UEFI Network Stack: checked
    Legacy ROM Options: checked
    SATA Operation: RAID (only the NVMe, no other drives)

    I’m booting from Legacy Onboard NIC.


  • Moderator

    @abrowning just for clarity, there is an issue between the linux kernel, uefi mode, and Dell systems using the intel sata adapter when the sata adapter is in “raid-on” mode. Switching the sata adapter to achi mode will (mask) the issue. This is a documented linux kernel issue and not specifically a fog issue. Commercial linux distributions suffer from the same issue.



  • @sebastian-roth said in Dell Precision T3620 with NVMe:

    @abrowning said in Dell Precision T3620 with NVMe:

    SATA Operation: RAID (only the NVMe, no other drives)

    This is the issue I’d say. Switch to AHCI mode and FOG should be able to see the disk. But be warned, an already installed Windows will have issues when changing this setting I reckon.

    Yep… I was about to reply that we had fixed the issue. :-P

    The network guy set another option on DHCP other than the 66 and 67 options (thought I’m not sure which) to enable UEFI Network boot and I changed it to AHCI and it works. Just changing to AHCI before without the other option set on DHCP didn’t fix it before though. This is the first time I’ve used FOG with a UEFI setup, but I knew it would be a simple fix. Thanks for your help!


  • Developer

    @abrowning said in Dell Precision T3620 with NVMe:

    SATA Operation: RAID (only the NVMe, no other drives)

    This is the issue I’d say. Switch to AHCI mode and FOG should be able to see the disk. But be warned, an already installed Windows will have issues when changing this setting I reckon.



  • It boots into the PXE menu without any issues, but when I do the check compatibility it gives me this message:

    Network…Pass
    Disk…Fail
    Try using a newer kernel that may be compatible with this device.

    I’m on the newest kernel that is available, so not sure what else I can do. It also gives me this info that I can use on the forum:

    00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-LM [8086:15b7] (rev31)


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.