Authentication ERROR: Could not authenticate : Value cannot be null.



  • Server
    • FOG Version: 1.4.4
    • OS: Linux
    Client
    • Service Version: 0.11.12
    • OS: Linux / Debian 8
    Description

    Hello,
    I have an error after installing the fog client on my debian machine, here are the logs related:

     13/09/2017 10:26 Main Overriding exception handling
     13/09/2017 10:26 Main Bootstrapping Zazzles
     13/09/2017 10:26 Controller Initialize
     13/09/2017 10:26 Controller Start
    
     13/09/2017 10:26 Service Starting service
     13/09/2017 10:26 Bus Became bus server
     13/09/2017 10:26 Bus Emmiting message on channel: Status
     13/09/2017 10:26 Service Invoking early JIT compilation on needed binaries
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     13/09/2017 10:26 Client-Info Version: 0.11.12
     13/09/2017 10:26 Client-Info OS:      Linux
     13/09/2017 10:26 Middleware::Authentication Waiting for authentication timeout to pass
     13/09/2017 10:26 Middleware::Communication Download: http://192.168.0.10/fog/management/other/ssl/srvpublic.crt
     13/09/2017 10:26 Middleware::Authentication ERROR: Could not authenticate
     13/09/2017 10:26 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
    
    

    I’ve tried to resetting the encryption, reinstall the client, I can also download the certificate manually with a wget command, … but still the same problem.

    A little help would be greatly appreciated,
    Thanks in advance.



  • It worked with the following versions : mono 3.10 and fog client 0.11.12 on a debian 7 system.
    Thanks !


  • Developer

    @ttbm I’ve just tried the fog-client on Debian 8 and it worked nicely. Here is a mono package list (including the versions) from that test system:

    dpkg -l | grep "ii  mono"
    ii  mono-4.0-gac                                                3.2.8+dfsg-10                        all          Mono GAC tool (for CLI 4.0)
    ii  mono-4.0-service                                            3.2.8+dfsg-10                        all          Mono service manager for CLI 4.0
    ii  mono-csharp-shell                                           3.2.8+dfsg-10                        all          interactive C# shell
    ii  mono-devel                                                  3.2.8+dfsg-10                        all          Mono development tools
    ii  mono-gac                                                    3.2.8+dfsg-10                        all          Mono GAC tool
    ii  mono-mcs                                                    3.2.8+dfsg-10                        all          Mono C# 2.0 / 3.0 / 4.0 / 5.0  compiler for CLI 2.0 / 4.0 / 4.5
    ii  mono-runtime                                                3.2.8+dfsg-10                        amd64        Mono runtime - default version
    ii  mono-runtime-common                                         3.2.8+dfsg-10                        amd64        Mono runtime - common files
    ii  mono-runtime-sgen                                           3.2.8+dfsg-10                        amd64        Mono runtime - SGen
    ii  mono-xbuild                                                 3.2.8+dfsg-10                        all          MSBuild-compatible build system for Mono
    ii  monodevelop                                                 4.0.12+dfsg-6                        all          Development Environment for GNOME
    ii  monodoc-base                                                3.2.8+dfsg-10                        all          shared MonoDoc binaries
    ii  monodoc-manual                                              3.2.8+dfsg-10                        all          compiled XML documentation from the Mono project
    

    If you don’t see anything in fog.log then run journalctl -u FOGService -f -n 50 while doing a stop/start (service FOGService stop; service FOGService start) in another terminal window.

    Post output here for us to check. I suspect you see something like mono-service: command not found. In case you see this, install debian package mono-4.0-service and you should be up and running.



  • Thanks for your reply, I tried with 2 different versions of mono but still the same, except that now the file “fog.log” remains empty, however this is what we can find in the file SmartInstaller.log :

    14/09/2017 11:21 Middleware::Communication Download: http://192.168.0.10/fog/management/other/ca.cert.der
    14/09/2017 11:21 Data::RSA Injecting root CA:
    
    

  • Developer

    @ttbm said:

    … Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority

    This means that the fog-client does not find the certificate on the client itself. This is usually due to a broken keystore in the mono installation. Can you try using older mono versions on your debian client?



  • I have tried the solutions present here : https://forums.fogproject.org/topic/10168/linux-client-could-not-authenticate
    but nothing changes


Log in to reply
 

393
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.