FTP issue cant create image



  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 17
    Client
    • Service Version:
    • OS:
    Description

    63 Error message : ftp_login : login Incorrect., host Username fog

    • Reattempting to update database
      *Error Returned: Type: 2 File: /var/www/fog/lib/fog/fogftp.class.php

    I worked through the https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP#Credentials_.2F_Passwords

    Still no change

    I’ve change the tftp user from “foguser” to fog and made sure the passwords match. set the pass for fog it states unchanged. made sure the firewall was off and not starting. Also check the configs and those match the knowledge base articles.

    Not sure what I’m missing.


  • Developer

    So I am marking this solved now. Feel free to open a new post in case you run into another issue.


  • Moderator

    @bigredcherokee I’m not sure what to tell you. If you followed the process I outlined and then reran the installer at the end it should be working.

    That process will be consistent when you upgrade next time. That is why we need to be sure to fix everything based on the .fogsettings file. You can change the password to what ever you like using the process, but its best to just let the fog installer pick a complex password for the service account and then not touch it afterwards.

    I’m glad you have it working now!! Well done.



  • okay weird but it looks like it erased the old pass but everything is working right now after the reinstall.



  • @george1421 * Press [Enter] key when database is updated/installed.

    • Setting up storage…OK
    • Setting up and starting DHCP Server… !!! No router address found !!!
      !!! No dns address found !!!
      OK
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up FOG Snapins…OK
    • Setting up UDPCast…OK
    • Configuring UDPCast…OK
    • Building UDPCast…OK
    • Installing UDPCast…OK
    • Installing FOG System Scripts…OK
    • Configuring FOG System Services
    • Setting permissions on FOGMulticastManager.service script…OK

    • Enabling FOGMulticastManager.service Service…OK

    • Setting permissions on FOGImageReplicator.service script…OK

    • Enabling FOGImageReplicator.service Service…OK

    • Setting permissions on FOGSnapinReplicator.service script…OK

    • Enabling FOGSnapinReplicator.service Service…OK

    • Setting permissions on FOGScheduler.service script…OK

    • Enabling FOGScheduler.service Service…OK

    • Setting permissions on FOGPingHosts.service script…OK

    • Enabling FOGPingHosts.service Service…OK

    • Setting permissions on FOGSnapinHash.service script…OK

    • Enabling FOGSnapinHash.service Service…OK

    • Setting permissions on FOGImageSize.service script…OK

    • Enabling FOGImageSize.service Service…OK

    • Setting up FOG Services…OK

    • Starting FOGMulticastManager.service Service…OK

    • Starting FOGImageReplicator.service Service…OK

    • Starting FOGSnapinReplicator.service Service…OK

    • Starting FOGScheduler.service Service…OK

    • Starting FOGPingHosts.service Service…OK

    • Starting FOGSnapinHash.service Service…OK

    • Starting FOGImageSize.service Service…OK

    • Setting up exports file…OK

    • Setting up and starting RPCBind…OK

    • Setting up and starting NFS Server…OK

    • Ensuring node username and passwords match…Done

    • Setup complete

      You can now login to the FOG Management Portal using
      the information listed below. The login information
      is only if this is the first install.

      This can be done by opening a web browser and going to:

      http://192.168.x.xx/fog/management

      Default User Information
      Username: fog
      Password: password

    root@Fogserver:~/fogproject/bin#


  • Moderator

    @bigredcherokee That’s very strange. The fog installer should set the linux user fog back to what ever value IS found in the .fogsettings file. password should have never been the default password for the linux user fog.



  • @george1421

    So far so good. Okay one question it set the fog account back to password. Should I go back and change the fog user account to what I found in the fog settings ?


  • Moderator

    @bigredcherokee Well my google-fu is failing me right now so I’ll have to retype it. Screen shots are not required at this time. Unfortunatly this is a common occurrence (reusing the fog system account for other purposes).

    1. Login with another user account that has sudo rights.
    2. Inspect the file /var/fog/.fogsettings (its hidden)
    3. Collect and document the value of password in the document. That is the password the fog account should be set to.
    4. Reset the linux fog user account to that password defined in step 3. You will use passwd fog to reset the account. Hint: If you log into your fog server using putty you can copy and paste text much easier than using the linux console.
    5. From a windows computer confirm that you can ftp to the fog server. Login with the user fog and the password collected from step 3. If successful proceed to the next step.
    6. Goto the FOG Web gui and FOG settings. Ensure the user ID in the tftp section says fog and the password matches the value collected in step 3.
    7. Go to the storage node configuration for this FOG server. Ensure the management id is fog and the management password is the same as you collected in step 3.
    8. Now go back to the fog server linux console and rerun the fog installer (./installfog.sh) to realign the remaining bits.
    9. Done.


  • @george1421 Will do. Thanks I have some screenshots of the errors would you want to see those?


  • Moderator

    @bigredcherokee To avoid issues in the future, I would surely use a different user account for system administration. Let me get the process to fix this.



  • Yes we use the account fog and password. I think were I went wrong was I restored a 1.2.0 config and then updated the db again. Everything else has been working until i tried up upload a image. I can use another account for administration that isn’t a problem.


  • Moderator

    Have you or do you use the linux user fog for system administration and/or changed the password to the account? If you do that is the root of your problem. We can get you back in sync, but you will need to use another user account for system administration.


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.