Isolated Network Connection Issues



  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 16.04 LTS
    Client
    • Service Version:
    • OS:
    Description

    I’m a novice when it comes to networking/imaging, so thanks in advance for your patience!

    I’m trying to get FOG up and running on a clean install of Ubuntu. My goal is to be able to image machines over an isolated network. I installed Ubuntu and FOG using an internet connection over an ethernet cable. I used the following settings:

    Server IP Address: 192.168.1.1
    Server Subnet Mask: 255.255.255.0
    Interface (FOG would not let me say no to changing the interface, so I had to use ifconfig to find the name of the ethernet port): enp2s0
    Installation Type: Normal Server
    Internationalization: 1
    Image Storage Location: /images
    Using FOG DHCP: Yes
    DHCP Router Address:

    Then, when FOG asked me to install/update my database schema, I disconnected FOG from the wired internet connection, plugged the machine into the isolated network switch, and used a second machine running Windows 10 to try and go to 192.168.1.1/fog/management. However, this did not work. Attempting to ping that IP did not work either. I did not set up any special networking settings with my Windows 10 machine; it is set to automatically retrieve IP and DNS settings.

    Does anyone have an idea of what I might need to do to fix this issue?


  • Developer

    @mikec96 said in Isolated Network Connection Issues:

    Even though I entered 192.168.1.1 into the Server IP address setting, FOG was actually using its previous IP when it was connected to the internet (which was 192.168.1.35).

    Did you manually change the server IP after/while running the setup? FOG does not change it for you! FOG uses the IP address in several places internally but it wouldn’t change the actual IP configured on the interface.

    Possibly you will run into one or the other issue with the changed IP. So please take a read through this as well: https://wiki.fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address



  • @Sebastian-Roth I’m not sure why the IP is 192.168.1.35 instead of the one I specified (if you have any insight as to why, I’d love to hear). Thank you for your help!



  • @Sebastian-Roth Never mind, I believe I solved my own problem. Even though I entered 192.168.1.1 into the Server IP address setting, FOG was actually using its previous IP when it was connected to the internet (which was 192.168.1.35).


  • Developer

    @mikec96 Please run sudo systemctl status isc-dhcp-server.service and sudo journalctl -xn on the FOG server console to see if it up and running properly.

    Does the server have a static IP? What do you get from sudo ip a s?

    Does you client get an IP, maybe a different one from another DHCP server on the network?



  • @Sebastian-Roth I’ve looked through the online forums/YouTube videos/articles/etc. but I have not been able to find other descriptions of the problem I’m having. It’s probably just a very simple error on my part, but I can’t seem to figure out what it is.

    The client did not get an IP address (I’m assuming that FOG should assign my Windows 10 machine an IP based on my current settings). Pinging 192.168.1.1 does not return anything.


  • Developer

    @mikec96 You might start by searching the forum and reading through posts like this: https://forums.fogproject.org/topic/10315/changing-my-fog-server-to-an-isolated-network

    Did the windows client get an IP? Can you ping 192.168.1.1 from that client?


 

434
Online

41.9k
Users

12.4k
Topics

116.7k
Posts