[Win 7 Image Upload] No partitions found



  • Hi everyone,

    I have a problem.
    During my vacation my colleagues accidentally overwrote my master image. So I have to create a new one.

    Device: HP 8200 Elite CMT
    OS: Windows 7 Enterprise x64 with Service Pack 1

    FOG 0.32 is running on an Ubuntu Server 10.04 LTS.

    So I installed Windows using the legacy “BIOS” mode, because as some of you might know, there are problems with FOG when using (U)EFI. I installed all drivers and applications needed. Then I syspreped the machine using an unattend file, which I successfully used before.
    When I try to upload the image, for some reason FOG says “No partitions found”. I can’t figure out why. The OS is definitely working fine. The HP computer shouldn’t be the problem, because I used the same type for imaging and deployment successfully in the past.

    What I’ve tried so far:

    • Sysprep without unattend file.
    • Chose a different image type. Usually “Single partition (NTFS resizable)” should work, because it did work in the past.
    • Took the HDD, put it in a different computer and tried to image it.

    Keep getting the same error.

    Maybe some of you have any idea or hint for me.
    Thanks in advance!



  • With the help of Michael’s thread here

    [url]http://fogproject.org/forum/threads/solved-task-is-complete-within-seconds-problem-with-gpt-mbr.1172/[/url]

    I finally was able to solve my problem. In my case it seems as if the GUID partition table and the MBR were confusing each other, so the Linux-FOG-Kernel couldn’t find any partitions.

    Here is what I did:

    [B]Please note:[/B]
    Since my computer was just a testing machine to create an image I did not backup anything before doing this. As recommended on the Fixparts webpage you should certainly do a backup (of MBR, system and data, or in other words everything ;-), if you’re going to do the following steps on an important machine/system.

    1. Download Fixparts for Windows from here:

    [url]http://www.rodsbooks.com/fixparts/[/url] (look for the link “download page”)

    1. Unzip the file and execute it with administration privileges. A command window will now pop up.

    2. Type in “0:” (this command is just for Windows!) to define your first (and in my case only) HDD to be the one to analyse.

    3. Now the tool suggests to delete the GPT signatures and asks you to confirm. If you want to use Linux as well as Windows on your disk you probably should not delete those signatures. But in my case I only want to use Windows, so I say yes.

    4. After that exit the tool by typing “w” (write changes to disk and quit). Restart your computer to check if it still works.

    5. Sysprep the OS and upload the image to FOG.



  • Some other things I’ve tried:

    • BIOS update from 2.15 to 2.21
    • tried the whole process with a different HDD

    Nothing solved the problem yet.

    If a developer reads this, maybe you can explain to me, when/why exactly FOG decides that “No partitions (were) found”. I don’t have any clue, because in this case that error message makes absolutely no sense to me. The OS is working fine and there are definitely partitions existent.
    By the way, the steps prior to imaging are finished successfully. But then it goes “An error has been detected”…


Log in to reply
 

362
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.