incorrect IPs in IPXE



  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu server LTS 16.04
    Client
    • Service Version: hyperV/HP 800 G1
      (Same error on VM and workstation)
    • OS: Windows 7
    Description

    DHCP is served from a separate windows server. Option 066 (ip for fog server) and 067 are (undionly.kpxe) is correctly configured. Initially IP address and option 066 are correctly passed onto the PXE boot process.

    Then when ipxe configures net0 with completely different information with IPs not even in the network scope. (see the below screenshot)
    0_1503661671967_fog ipxe error1.PNG

    I manually configured ipxe ‘config’ command and it worked fine.

    DHCP is configured with a second failover server (windows). I’ve double checked there are no other proxyDHCP or a rouge DHCP server connected to the network. Could someone shed some light into this issue. Is there any thing should I manually configure in FOG server?

    Thanks In advance.
    K



  • With help From Geroge1421 we discovered that there was a rouge DHCP server connected to the network. It was running from a VM on a regular PC. Network admins were able to locate the port relates to the MAC address of the rouge server.

    Now PXE is booting to FOG smoothly


  • Moderator

    After reviewing the pcap file we found there IS a second dhcp server on the OP’s network. The OP is currently addressing the second dhcp server issue.



  • @george1421 Thanks. Starting to do that now : )


  • Moderator

    If you follow these instructions and capture a pcap of the pxe booting process we can tell what is going down the wire. For this test your dhcp server, fog server, and pxe booting client should be on the same subnet so that we can see the entire pxe booting conversation. Capture the pcap and post to a google drive or dropbox. Either post the link here or send me an IM and I will take a look at it and tell you what is going on.

    https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue


  • Moderator

    It really sounds like you have two or more dhcp servers in your broadcast domain .



  • I checked PXE on multiple PCs they all get a unique IP assigned in 192.168.30.xxx range. My DHCP settings are in 172.16.1.xxx range


Log in to reply
 

443
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.