Can't capture image, looks like permissions, but can't see how it could be



  • Server
    • FOG Version: 1.4.4
    • OS: Debian 9
    Client
    • Service Version:
    • OS: Windows 7
    Description

    After not using fog for a time it will no longer capture images. It gets all the way through the capturing process and then fails with this error:

    alt text

    So, figured its a permissions issue, checked those, didn’t see any problem. Was able to FTP to the location and grab the specified file with the same credentials.

    Got fed up with it, and set permissions to 777

    alt text

    Same error. I’m at a loss. At this point I’ve updated Fog (started with 1.4), updated/upgraded Debian (started with 8 ), messed with all kinds of permissions, including removing the account and re-adding it. I really don’t want to have to start over and reinstall everything.

    Whats most frustrating is I had the same problem yesterday, and resolved it, but today back to this problem and now I can’t fix it.



  • That did it! Thank you guys!



  • Ok, fixed that and capturing a new image now, but I have to head home for the day. I’ll update tomorrow, but I bet that’s it.

    Awsome guys, thank you. Especially you Sebastian for wracking your brain over it!


  • Developer

    @george1421 Awesome man! We had this before and I remember noticing it after staring at the error pic long enough… but not this time. Great you found it!!!


  • Moderator

    Just for something abstract, is 10.2.0.87 your FOG master node server?

    Oh, what the hell is that?? image name =v2Office365-SymFix/18 Why is that forward slash ( / ) in the file name? What you have done is allowed in FOG, but I don’t think that is what you really intended here. By putting the forward slash in there FOG will look for a directory called v2Office365-SymFix and place the image in a image directory named 18 This allows for grouping of like Images. If this isn’t what you intended, replace the forward slash with something other than a special character.


  • Developer

    @ENorum Well then, I have to admit, I am out of ideas for now. But I am sure others here in the forum have new ideas.

    I am still wondering why this is working properly using a FTP client. Could you take a picture of when you move a directory (including files) from /images/dev/abc to /images/test?



  • Had that problem, moved the server and added more diskspace 6 months ago.

    alt text


  • Developer

    @ENorum Maybe there is just not enough space on disk?? Run df -h and post a picture here.



  • Yeah, sorry. Not really familiar with Linux. I was able to move files and folders around in those folders.

    alt text


  • Developer

    @ENorum I suppose I should have explained more clearly on what to test using the FTP client. What FOG does at this stage is move the just uploaded image from /images/dev/<MACADDRESS> to /images/<IMAGENAME>. So please try moving a directory like described above (same locations in the filesystem). I doubt this will work.

    Please post what you get when running ls -al /images /images/dev on the command line of yor FOG server



  • @sebastian-roth Sorry, yes, using an FTP client.

    And yes, I can perform all of those actions using the FTP client.


  • Developer

    @enorum said in Can't capture image, looks like permissions, but can't see how it could be:

    So fixed that, so now I’m able to connect, authenticate and send files to all of those directories.

    You mean using a FTP client software? Please try creating files (upload), creating a directory, moving and deleting files… see if all possible file/dir operations work using a standard FTP client.



  • So went through and checked permissions on all of those folders, they were good.

    Went through the FTP troubleshooting article, found that the FTP service was misconfigured, I was able to connect and authenticate, but not able to send files to the server. Found the vsftpd.conf had a line that we needed that was commented out:

    Uncomment this to enable any form of FTP write command
    write-enable=YES

    So fixed that, so now I’m able to connect, authenticate and send files to all of those directories.

    However, fog still fails with the same error message.


  • Developer

    @ENorum Follow George’s instructions plus you might want to checkout this: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP


  • Moderator

    Lets first talk about what is going on behind the screen here.

    When you capture an image with FOG, it uploads the image to /images/dev/<mac_address>. Once the capture is complete the target computer logs into the FOG server over the FTP protocol and requests the /images/dev/<mac_address> directory to be moved to /images/<image_name> using the linux service account called fog This is the point at which your image capture is failing.

    The linux user fog needs to have Read/Write/Execute permissions to the /images and /images/dev directories for this transfer to happen. So I would start there to ensure that the fog user can do what is needed.


 

474
Online

41.7k
Users

12.2k
Topics

115.1k
Posts