Can't load web portal, PXE boot fails



  • Server
    • FOG Version: Not sure
    • OS: Ubuntu 16.04
    Client
    • Service Version:
    • OS: Win10
    Description

    Sorry for the lack of description info. I believe I am running FOG 1.3.x but forgot how to check what version it is. Spent a good few weeks building an awesome FOG server with the help of the good people of these forums, and used it quite a bit, but then it sat idle for the past month. Just enough time to forget how to traverse and work with Linux/Fog (SHAME!). I tried accessing the web portal and it does not get to the login page, but if I just use the IP without the /fog/management it connects to a FOG page with a couple of links. Also, PXE booting fails with the following error messages (screenshot included):

    I tried doing a little research and saw maybe a mysql database error, but I could not run some of the terminal statements listed. I also saw to maybe try reinstalling FOG but wanted to checkin before doing so. Not sure if that would remove my previous images and pc objects in FOG. Any help getting me back in and up and running would be greatly appreciated and thank you ahead of time.
    0_1502915431019_Screen Shot 2017-08-16 at 3.13.14 PM.png



  • @george1421

    I am now fully operational and up to date to boot! Thank you very much for your time Mr. George1421! It’s much appreciated.


  • Moderator

    @merilious Do you already have a fogproject directory? If you are on an RC release I might say yes.

    It might be in /root/fogproject or /opt/fogproject depending on who’s instructions you followed. If you can find that fogproject directory, then the update process is simple.

    cd /root/fogproject
    git pull
    git checkout master
    cd bin
    ./installfog.sh
    

    You will need to do a checkout master because you were on a rc branch.



  • @george1421

    That did it! I ran the remove unattended updates at the bottom as well.
    So now to update the FOG install. Just to make sure I do this correctly I run the following correct?

    git clone https://github.com/FOGProject/fogproject.git /root/fogproject .
    
    cd /root/fogproject/bin
    
    ./installfog.sh
    

    Or should the install line be:

    php_ver='7.0' php_verAdds='-7.0' ./installfog.sh -y
    

    Just grabbing info from around the Wiki and stuff.


  • Moderator

    @merilious OK I just wanted to make sure that the password was blank. Then the instructions in the thread are spot on. Go ahead and follow the steps. Then you probably should update to current 1.4.0 had several issues with single disk resizable that was fixed in 1.4.1. But for now you need to get control of your fog server.



  • @george1421

    snmysqlpass=’’

    Also, the FOG version up top states:
    Version: 1.4.0-RC-8
    Install time: Tue 25 Apr 2017 04:50:18 PM CDT


  • Moderator

    @merilious I want you to open a linux command prompt and review the settings in /opt/fog/.fogsettings especially the field snmysqlpass what is the value currently?


  • Moderator

    @merilious Since it WAS working and magically, IS NOT working AND you are running ubuntu this thread probably applies: https://forums.fogproject.org/topic/10006/ubuntu-is-fog-s-enemy

    But before you go and follow this thread blindly lets get some background information.



  • @george1421

    “A valid database connection could not be made”


  • Moderator

    ok I want you to run the following command from a windows computer browser.

    http://10.100.10.22/fog/service/ipxe/boot.php?mac=00:1c:42:86:14:c4
    Post the output here.


Log in to reply
 

473
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.