Unable to restart DHCP and TFTP services using default password after 1.4.4 update



  • Server
    • FOG Version: 1.4.4
    • OS: Kubuntu
    Client
    • Service Version:
    • OS:
    Description

    I recently updated to for 1.4.4 from 1.3.x. Prior to update I was able to restart the TFTP and DHCP services using the default password (password) but since updating to 1.4.4 I am no longer able to restart these services as it will not accept the default password any more.



  • Fixed, we appear to be uploading now.


  • Moderator

    @mattbrown said in Unable to restart DHCP and TFTP services using default password after 1.4.4 update:

    We’re now logging in as fogadm so could that be the conflict?

    NO DON’T change this!

    If you have changed the linux user fog you will break fog. That user account us under the management of the fog installer and its backend processes.

    OK, what you need to do is review the password defined in /opt/fog/.fogsettings. Note what this password is.

    Then, go to the web gui and confirm that in:

    1. The storage managment -> Storage node (I think its was DefaultStorage) way down at the bottom, ensure the management user (fog) and management password are consistent with the .fogsettings file.
    2. Then in FOG Configuration -> Fog Settings under the TFTP Server ensure the password is consistent with the .fogsettings.

    My bet is one of those are inconsistent with the .fogsettings file.



  • George ,

    We’re finally booting computers into fog and pulling images, but now we are receiving the following after creating the image:

    Attempting to update database…Failed
    Error returned: Type 2, File: /var/www/html/fog/lib/fog/fogftp.class.php,
    Line: 463, Message: ftp_login(): Login incorrect., Host: 168.[XX.XXX.XX], Username: fog

    We’re now logging in as fogadm so could that be the conflict? I tried changing the FTP username and password but it still said username fog. Is that in fogsettings.sh?


  • Developer

    @MattBrown Please let us know if you got things working or if you still need help. We’d mark this thread solved if things are fine.


  • Moderator

    @sebastian-roth I forgot updating this thread yesterday. After a chat session we agreed to do a TV session. There was a number of things that went wrong with the upgrade. The first was using the linux fog account for system management. The fog installer change the linux fog user’s password to something and (I feel) the fog installer didn’t complete the first time since not all of the info was saved to the .fogsettings file. So the fog user password was not saved in the .fogsettings. It was a bit of a bad situation.

    The OP had to go through the ubuntu password recover process to gain control of FOG server’s fog account. Once that was done, he created a new user for FOG server administration and then switched to that account for system administration. He was using isc-dhcp for the imaging dhcp server on an isolated network because of some incompatibilities with the primary dhcp server on the business network. When trying to complete the 1.4.4 upgrade again the installer was aborting because of some missing settings in the .fogsettings file. We decided to disable the isc-dhcp server and switched over to dnsmasq to supply the missing pxe boot information. We had to call off the debugging do to end of business day. He has to get with his networking engineer to update their dhcp-helper service to include the FOG server IP since the fog server is on one subnet, dhcp server on another, and the pxe booting clients on several other subnets.

    I feel the OP is pretty close to getting his fog server operational again with everything connected to the business network.


  • Developer

    @MattBrown Updating to 1.4.4 was definitely good, no question. A lot of people use the fog acount but as George said it’s not advisable if you don’t know for sure what you are doing.
    I am not sure what the user management tool looks like in Kubuntu but I am sure you’ll find it somewhere. Add a new user there (call it mradmin or whatever you like) and make sure to add it to the group sudo.
    For the password of the user fog you might have a look in /var/www/fog/lib/fog/config.class.php. Find TFTP_FTP_PASSWORD there. The installer checks both files and uses the the later one if password is empty in .fogsettings file. You don’t need that password as you have a new sudo user now! But still you might want to copy&paste it into your /opt/fog/.fogsettings file to prevent confusion in the future.



  • @george1421

    When I go to “Password and User Account” under system settings it says the username is fog. This is in production. I was using it successfully on version 1.3.x, but was unable to image our newest computers. After a quick google search the consensus seemed to be to update the server to fog 1.4.4. Thats when I began having problems.


  • Moderator

    @mattbrown Is this fog server in production or are you still in a pilot phase?

    What linux user account do you use to manage this fog server?



  • @george1421

    I’m using whatever defaults I was given in the youtube walkthrough I used when installing, so its possible. Admittedly I am nowhere near a (K)ubuntu expert. I’m learning as I go. When I go to /opt/fog/.fogsettings and look at the password line it simply says

    password=" "

    I attempted to return a blank for the password when restarting the services but that did not resolve it. I didn’t want to change the entry via VI without knowing what I was doing or asking advice. Should I change it there?

    If not how do I resolve the issue, or fix it so that I don’t have to restart the services after rebooting the server (Ive had this problem since installing 1.3.x)


  • Moderator

    @mattbrown Are you by chance using the linux user fog for system maintenance? That user account is an internal FOG only user account. The installer will take over that user account every time fog is installed or updated.

    HINT: You can find the password that the installer sets the linux fog account to in the /opt/fog/.fogsettings file.



  • Sebastian,

    Thank you for your reply. I am attempting to restart services using the following two commands:

    sudo restart tftpd-hpa
    and
    sudo start isc-dhcp-server

    When I enter the commands it asks me for:
    [sudo] password for fog:

    Historically, I have used the default “password” for this but now its telling me "sorry, try again.


  • Developer

    @MattBrown Which passwords do you mean? sudo or what? Please explain.


Log in to reply
 

503
Online

38925
Users

10691
Topics

101434
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.