Help trying to create USB PXE Boot - Where is ipxe.efi?



  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 16.4.4
    Client
    • Service Version:
    • OS:
    Description - Hello, I am trying to follow the guide to create a bootable USB drive for the PXE boot sequence. I am not totally new but not all that experienced in Linux. The guide says to go to /tftpboot/ipxe.efi and copy the ipxe.efi file, however I am unable to locate it in the Linux OS.

    Can someone help me with the full path?


  • Moderator

    @caw001 If that is the process you followed then something is not right with either the fog server or the usb module. Let me look into it. The kernel parameters don’t look correct. There should be more info in the kernel parameters almost like the grub config file is damaged. It should list the web server and storage info.



  • @george1421 Thank you. I “think” I am where I need to be, but still getting the same error. I created the host. I created the image (then went back and assigned it to the host) and then was able to schedule the capture task. However I am still getting the same error when trying to run the capture task from the machine.

    Is there something else that I am missing?


  • Moderator

    @caw001 You hit one of the caveats of booting this way. The fix is simple.

    Schedule the capture/deploy task first then usb boot and select capture.

    The very poor error above should say (IMO)“Hey dummy, give me something to do before booting me via usb” but the developers nixed that error message.



  • @george1421 I’d like to say last question, but I know better… I managed to get my host registered. Whether or not this equates to scheduling the import I don’t know. However, after registering the host and selecting image deploy/capture I am getting the following error: see screenshot if it attaches

    0_1502304866728_fogcaptureerror.JPG



  • @george1421 You mentioned that when using the USB boot image that I need to schedule the import of the image as well as the imaging job itself. I am having trouble locating how to do that. I don’t see any way to create a new scheduled task. Are these supposed to be created under Import hosts?


  • Moderator

    @caw001 You will want to follow these instructions: https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image

    I’m going to chat you some additional steps you can take. Look at the talk bubble on the FOG forums tool tray.



  • @george1421 I’m guessing the last option is probably the one we would need to choose within our network. At least for now. WDS also uses PXE so I can’t mess with anything that will search for that on DHCP such as the DHCP Proxy.

    Booting into the FOG engine is what I thought I was trying to do with the ipxe file. Apparently I did not understand what I was reading but I thought I would be able to point it directly at the FOG server for booting.


  • Moderator

    @caw001 said in Help trying to create USB PXE Boot - Where is ipxe.efi?:

    I’m using WinSCP on a Windows client.

    WinSCP will work to move that ipxe.efi file to the external computer.

    Just for clarity, what instructions are you using to create this ipxe boot drive?


  • Moderator

    @caw001 The path you are going down will not work since you are trying to load iPXE which will then require dhcp I’m thinking the next server from dhcp will confuse the iPXE kernel.

    If you can put the fog server and target computers on their own vlan (subnets) then we can make this work with FOG.

    IF this path doesn’t work then we will take you through usb booting right into the FOS engine (the customized linux OS that captures and deploys to the target computers).

    We have a number of options some are better than others.


  • Senior Developer



  • I’m using WinSCP on a Windows client.

    We currently have a Windows WDS server in production on our network. We are testing FOG because of its ability to work with multiple operating systems. I cannot change our production DHCP to point to FOG for testing, so I am trying to create a bootable USB drive that I can use to PXE boot directly to the FOG server without using DHCP to get that information.

    From the command line on the fog server if I try to cd to /tftpboot I receive the message no such file or directory. I’ve been unable to locate this folder.


  • Moderator

    Also understand that usb boot will only work for uefi systems. The bios / legacy is not supported by usb booting into the FOG menu. We have other ways to get there.

    Why are you going this route? What problem are you trying to solve?


  • Senior Developer

    It’s literally in the lcoation stated.

    /tftpboot/ipxe.efi

    If it’s not there, then my guess is the installer didn’t complete or somebody deleted the file.

    From Terminal you can copy this file to your desktop with (if you installed the Linux OS with a GUI):

    sudo cp /tftpboot/ipxe.efi ~<username>/Desktop
    

    Just replace <username> with the username you created and are logged in with.


Log in to reply
 

393
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.