• Hello awesome Fog Community,
    On my source machine I have a 512GB Samsung EVO M2 NVME SSD with a 475GB NTFS Partition (the partition has been shrunk to that size in an attempt to get around the issue below the drive only has about 200GB in use). This is just the data-drive of a build-machine who’s OS runs off a traditional SATA SSD so it doesn’t have any other partitions or special configurations.

    It’s failing to capture as a “Single Disk Resizeable” (gave error “disk contains an unclean file system” however I did perform every test possible and it IS good/clean). I have it currently captured as a “Multi-Partition Single Disk” capture (though it captures successfully as a RAW as well). When attempting to deploy the image to an identical M2 NVMe drive it fails immediately stating “Target partition size(500107 MB) is smaller than source(511060 MB). Use option -C to disable size checking (Dangerous).”

    TLDR; So I’m rather stuck, although i’m using identical drives – the image won’t deploy when captured, and I can’t capture it as a re-sizable partition.

    My thought is I either need to capture it as resizeable, or determine how to shrink the image ON the fog server itself. I’d really appreciate any insight you guys might have.

  • Senior Developer

    What’s the contents of that system’s image d1.fixed_size_partitions.

    What’s the contents of:

    cat /images/<imagename>/d1.fixed_size_partitions
    cat /images/<imagename>/d1.partitions
    cat /images/<imagename>/d1.minimum.partitions

    This, too me, sounds liek the image was captured before our tests for “fixed” partitions became a little more proper and it resized something that was expected to be fixed size. What partition was it giving this issue on?

  • @x23piracy

    Fantastic advice and right on the money. The windows 10 hybrid shutdown is what caused the unclean file system error and explains why the Windows 10 DART disk never picked up the error because it saw it as “normal”. That let me successfully capture and deploy the image on the NVMe.


    For full documentation: Fog version 1.4.4 - bzImage 4.12.3/bzImage32 4.12.3

  • try to shutdown your windows with:

    shutdown -s -t 0 -f

    then capture (i assume u are capturing windows).

    It’s because shutdown /s performs a conventional shutdown. The shutdown via the GUI performs a fast shutdown for Windows 8 & 10, where it does something that’s pretty much like a hibernation, so that startup and shutdown are fast.


    If you permanently like to disable that you can use (admin rights needed):

    powercfg -h off

    You don’t need to increase the partition yourself, fog will do that before it captures everything 😉

    Regards X23

  • Senior Developer

    @dang_that_guy said in NVMe Imaging Problems:

    Target partition size(500107 MB) is smaller than source(511060 MB).

    This is most probably because the disks aren’t identical in size! You need to know that 512GB disks do not all have the exact same amount of sectors/space. That’s how it is.

    As well it would be great to see the actual partition layout (and size) of those disks. So please schedule a debug capture job for the source machine and when you get to the shell run fdisk -l /dev/nvme0n1. Take a clear picture and shut off the machine. Do the same thing with the destination machine/disk (doesn’t matter if you schedule deploy or capture, just make sure it’s a debug job) and post both pictures here.

    As well we need to know which version of FOG you are running as Tom said. Otherwise we are not able to help you.

  • Senior Developer

    We need information. What version of FOG are you using?