PXE Boot Issues



  • Server
    • FOG Version: 1.5.0-RC-6
    • OS: Ubuntu
    Client
    • Service Version: ?
    • OS: Windows 7
    Description

    I’m having issues booting some of my machines into Fog. But some work. For instance, I have a ThinkPad L440 model that boots into the Fog menu fine. My VM’s I use for creating images still boot into Fog fine. But I have a Dell Latitude E6440 and another model that do not boot.

    For troubleshooting, I updated my Fog environment to 1.4.4 (latest stable release) and that did not help. So I went ahead and upgraded it to 1.5.0-RC-6 (latest trunk version) and that did not help either. I also tried upgrading the BIOS on the Latitude E6440 to the latest and that didn’t help either. I’ve tried different cables, different networks, different computers with the same model etc.

    Posting here is my last resort. I’m not sure if there are logs on the Fog/Ubuntu server that will tell me why it won’t boot into the Fog menu or if there is something else with legacy/UEFI boot modes. Or if the iPXE boot menu or boot exit settings need to be something different. I need help. Picture attached is what my machines get when trying to PXE boot into Fog.

    0_1501703747368_IMG_1839.JPG



  • The issue looks to be fixed since I changed the boot file name. This thread can be marked as closed/solved. Thanks again for everyone’s help.



  • @george1421 Got it. I’ll be sure and put all this down in my notes if I see another issue down the road. I appreciate your help.


  • Moderator

    @donutsrule5 Just for clarity, (choosing ipxe.kpxe isn’t a bad decision) the undionly,kpxe driver is the most common used because it uses the undi driver built into each network card. This driver supports the most network adapters because almost all network drivers have undi built in. With that said some implementations of undi is broken which cause undionly.kpxe to fail. The kernel ipxe.kpxe contains all of the known drivers provided by the iPXE group. So this kernel “should” work on all of the common network interfaces.



  • @george1421 Thank you for your help and insight. I confirmed with the models that don’t work (as well as the models that do to compare BIOS’s) that they are using legacy mode and not using secure boot etc. I am using the built in Ethernet port into the laptop or desktop, no kind of docking station. In response to @Sebastian-Roth post, I changed my bootfile name from undionly.kpxe to ipxe.pxe and got at least the E6440 model to boot into the Fog menu. So i’m off to try the others.



  • @sebastian-roth You are THE man. I changed my DHCP option from undionly.kpxe to ipxe.pxe and my E6440 booted right into the FOG menu. I’m going to try the other models later this morning to see if they are working as well. I’ll reply back to this thread if it gets everything working. This is a promising start!


  • Developer

    @donutsrule5 Please try different iPXE binaries. For legacy try undionly.kkpxe and ipxe.pxe - for UEFI ipxe.efi, snp.efi and snponly.efi… Let us know what happens which each of those.


  • Moderator

    @donutsrule5 said in PXE Boot Issues:

    Posting here is my last resort.

    I can tell you the 7440s pxe boot just fine into FOG. And for the record, you are not quite into FOG just yet. You are at the process of attempting to load the iPXE (separate FOSS project) kernel.

    The boot image appears to be undionly.kpxe can you tell me if the target computer is in uefi or bios (legacy) mode?

    If your computer is in uefi mode 1. you are sending the wrong kernel name to it you need ipxe.efi 2. you need to ensure that secure boot is disabled.

    Are you using the built in network adapter or some kind of usb/docking station nic? This error is unique and I personally haven’t seen it just yet.


Log in to reply
 

431
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.