HP Proliant DL580 G4



  • I tried many times to boot from lan but with no success, also to mention that i get a red fog menu with black background. I update firmware for both NICs to the latest versions, and I tried with a usb ethernet adapter tp-link UE300 but I don’t see it recognized by the BIOS, it tells me at boot menu only removable device

    2_1501706032885_3.jpg 1_1501706032885_2.jpg 0_1501706032885_1.jpg


  • Moderator

    @firej8 if your fog server and pxe booting client are on the same subnet you can use the fog server to eves drop on the pxe booting process. Here is a tutorial: https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    Upload the pcap file to a google drive or dropbox. If you are uncomfortable posting the link to the form use the forum direct message and send the link to either Sebastian or myself and we’ll take a look at the pcap and keep it private. When we have an answer then you are free to tear down the pcap from your google drive.



  • @sebastian-roth this picture you are talking about was old, when I tried yesterday the post was bzImage… ok .
    Would you give me the instructions to get some sample of the packet capture you want?


  • Moderator

    @firej8 Lets make sure I understand this.

    You have 2 different computers plugged into the same cable and both have issues getting dhcp address (that is the message that ipxe is saying in your picture of the client.

    If this is true, I’m still leaning towards a spanning tree issue.

    Bad cable perhaps?


  • Developer

    @firej8 I just noticed that in one of the pictures you send in the intial post shows bzImage32... ok. I don’t think this is actually causing the issue but it seems like iPXE does not recognize the system as 64 bit and therefore a 32 bit kernel is handed over.

    Drivers for those cards have been in the kernel for a very long time (BCM5706 - bnx2 and BCM5703 - tigon3). I don’t see why this could be an issue of missing drivers as we see that the NICs (eth0, ...) are recognized and udhcpc tries to get an IP on those interfaces.

    I think we need to tackle this by looking at the actual network packets. As you seem to cover all the IPs in pictures I guess you are not happy to share a wireshark/tcpdump packet capture file with us?! But I don’t really see another way of finding what’s wrong. Anyone got another idea?



  • @sebastian-roth I booted with a fedora 26 x64 live DVD. I got this:
    0_1501776171214_2.jpg



  • @george1421 I test the client with the same cable on the same switch I get this : 0_1501773807698_1.jpg


  • Moderator

    Moderator’s note: These may not be related, but cross linking threads: https://forums.fogproject.org/topic/10564/failed-to-get-an-ip-via-dhcp


  • Developer

    @firej8 RAID is definitely an issue. Search the forums for ‘raid’ and you will find some suggestions on how to make this work. But focusing on the network/PXE boot for now is a good idea!

    As I found out here there seems to be an “Embedded Dual NC371i Multifunction Gigabit Network Adapter” in that server. But I cannot find out what exact ethernet chip that is. Some say it’s a broadcom chip but I find different hints as well. Please boot a linux system (possibly live linux DVD) on that server, run lspci -nn | grep net and post the full text or a picture of the output here.


  • Moderator

    @firej8 If you plug a pc client into the same jack that went to the DL580, it works? We need to eliminate the “network” as the issue.

    The next step after the network has been eliminated is to boot this dl580 using a live linux cd. You can use ubuntu desktop live, or linux mint 18.2 any where you can boot and get to a linux command prompt.

    Once booted with a linux live dvd, then we can check to see if plugging in one network port will get an ip address.



  • @firej8 said in HP Proliant DL580 G4:

    @george1421 I didn’t want unmanaged switches so I have some managed. The Server has one network adapter as main, two again on mobo and a scsi network card with one more. Yes I had some hp dx2300 and (some laptops).

    So I think that switches aren’t a problem because with the same switches or with same topology the pc clients working.



  • @george1421 I didn’t want unmanaged switches so I have some managed. The Server has one network adapter as main, two again on mobo and a scsi network card with one more. Yes I had some hp dx2300 and (some laptops).


  • Moderator

    @firej8 Well your raid disk may be an issue, but right now lets focus on the network. FWIW on most switches spanning tree (default mode) is enabled by default, because it is a good idea.

    How many network adapters are in this server?

    And I guess I need to ask, does/has this fog server image other computers? I want to rule out an incorrect setting on the fog server.



  • @george1421
    I didn’t setup any settings about spanning tree but i thought too that my switch catalyst 2960-S was the problem, but now I tested on a 5port switch together and again no success. I forgot to tell you that I receive an error at the end of run: Cannot find disk on system (getHardDisk), is it because of scsi raid 1 ? I change the arch to x64



  • @quazz Fedora 25 x64 in virtualbox
    FOG Server Running Version 1.4.4
    SVN Revision: 6077


  • Moderator

    Server OS?
    FOG Version?


  • Moderator

    I guess let me first say that FOG is intended for Workstation class computers not servers. Typically servers have specialty hardware that requires unique drivers which are not common in the standard linux kernel.

    With that said it looks like FOS has the right drivers for the DL580 because it is seeing the network interfaces (Yes!!).

    Your network interfaces are being seeing by the iPXE kernel because you are getting into the FOG iPXE menu, it just appears that FOS (customized linux OS that captures and deploys images) is having a hard time connecting to the network.

    In one of your pictures, the condition reminds me of a networking issue with Spanning Tree protocol, in that you have the default spanning tree protocol enabled and you are not using one of the fast protocols (RSTP, MSTP, fast-STP, or what ever your switch manufacturer calls it). An easy test for a spanning tree issue is to place a dumb (unmanaged) switch between the pxe booting computer and the building network switch. Then pxe boot.

    Lets try this before we move on to the next step.

    Oh, one thing I noticed from your second picture is that FOG is sending the 32bit kernels to this DL580, I find that a bit odd since this is surely a pure x64 bit system.

    Lastly, the pictures are great because they explain the context of the errors very clearly, well done!


Log in to reply
 

746
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.