Dell Latitude 3570 pxe



  • Hate posting back to back threads but didn’t want 2 issues on the sames one. Ok, running 1.4.4 on Ubuntu 16.04 (Probably not the best choice). Now the Dell Latitude 3570 will register just fine BUT when i try to pxe boot, it just loads the grub, no matter what the task is. If i remove the host then I can access the FOG menu, but re-added the host and it’s back to loading gub. Since these 3570 are newer, is it a driver issue, not compatible with the current kernel? I will add that I did make sure I was on the latest kernel 4.12.3. Thanks.



  • @george1421 Yes it is, thanks.


  • Moderator

    @jphipps I’m having a hard time believing a kernel update fixed it, but if you have it working then job well done!!

    Is it safe to solve this thread?



  • @george1421 said in Dell Latitude 3570 pxe:

    @jphipps well if you hit enter a few times at the screen with the text it should drop you to a linux command prompt

    At the FOS command prompt key in cat /proc/cmdline and post the results here. My bet is that isdebug=yes is in the kernel parameters.

    Make sure you don’t have a lingering task that someone has scheduled, where someone was doing a debug capture or deploy.

    Made sure no tasks were scheduled, went ahead are updated the kernel again with most current and now all is working. I have been looking on the forums all day to figure out what was going on and it boiled down to one simple line and 2 seconds to update the kernel. Thanks for the help, it is appreciated!


  • Moderator

    @jphipps well if you hit enter a few times at the screen with the text it should drop you to a linux command prompt

    At the FOS command prompt key in cat /proc/cmdline and post the results here. My bet is that isdebug=yes is in the kernel parameters.

    Make sure you don’t have a lingering task that someone has scheduled, where someone was doing a debug capture or deploy.



  • @sebastian-roth said in Dell Latitude 3570 pxe:

    @jphipps said in Dell Latitude 3570 pxe:

    but when you issues any task, no matter which task it is, is when it boots into the FOS environment

    Well, I still don’t get what you mean I think. What’s wrong with the client booting into the FOS environment if there is a task for this host scheduled??? From my point of view everything is working as expected. Which task did you schedule?

    Doesn’t matter which task it is, capture is what I need to do but if i schedule deploy or any advanced task it loads FOS.

    @george1421 said in Dell Latitude 3570 pxe:

    @jphipps Just so I’m clear, every time you boot into FOG you get the first screen?

    This is telling me you setup a capture / deploy with debugging enabled - OR - someone setup a global fog kernel parameter where isdebug=yes

    I will look into the global parameter, never thought about that being the issue. I haven’t set one personally but I colleague that has messed about with the server who I have banned from touching it (was messing with this he shouldn’t have)


  • Moderator

    @jphipps Just so I’m clear, every time you boot into FOG you get the first screen?

    This is telling me you setup a capture / deploy with debugging enabled - OR - someone setup a global fog kernel parameter where isdebug=yes


  • Developer

    @jphipps said in Dell Latitude 3570 pxe:

    but when you issues any task, no matter which task it is, is when it boots into the FOS environment

    Well, I still don’t get what you mean I think. What’s wrong with the client booting into the FOS environment if there is a task for this host scheduled??? From my point of view everything is working as expected. Which task did you schedule?



  • @sebastian-roth said in Dell Latitude 3570 pxe:

    @Jphipps Do I understand this correctly? Even if there is no task scheduled for this hist it still boots right into the FOS linux environment?!

    Can you please open the following URL in your browser and post the full text you see here in the forum:

    http://10.78.0.33/fog/service/ipxe/boot.php?mac=10:7d:1a:10:f8:15

    I should have worded that better. When there is no task it will load the menu correctly but when you issues any task, no matter which task it is, is when it boots into the FOS environment. My apologies, that was a misleading error on my part.


  • Developer

    @Jphipps Do I understand this correctly? Even if there is no task scheduled for this hist it still boots right into the FOS linux environment?!

    Can you please open the following URL in your browser and post the full text you see here in the forum:

    http://10.78.0.33/fog/service/ipxe/boot.php?mac=10:7d:1a:10:f8:15





  • 0_1501612804682_0679D691-E2EA-4B86-B862-5E9EBB887175.jpg


  • Moderator

    @jphipps Can you give us a clear screen shot of the error taken with a mobile and when exactly in the pxe booting process it pops up?



  • Stock kernal, I don’t see a point in manipulating what works. On the console for the specific host I have BIOS set to sanboot and EFI set to refind. I’ve tested several other stations and these 3570 seem to be the only ones having and issue.


  • Moderator

    If you are building your own custom kernel then we can’t help you.

    The 3570s should be similar to the 7270s, which I can tell you works. The grub menu is a bit troubling (if this is truly a grub menu since that is only an option of iPXE exit).

    Typically the exit mode for bios systems is sanboot and the exit mode for uefi systems should be rEFInd.


 

540
Online

5.4k
Users

12.6k
Topics

118.8k
Posts