AWK: fatal: cannot open file error



  • Server
    • FOG Version: 1.3.0-RC-20
    • OS: Ubuntu 14.04 LTS
    Description

    I started seeing new behavior on deploying an image today. First the deployment changes the UUID for the disks (previously it didn’t do this) then after “Resetting swap systems” I get the error:

    awk: fatal: cannot open file ‘/images/XXXXX/d2.original.swapuuids’ for reading (no such file or directory)

    This error happens 4 times in a row on-screen and then the system reboots. The fog server seems fine itself, permissions/file ownership is as per standard, and I have tried different target hardware and different image files and ran the script to update the init.xz and bzImage as well as their 32 versions via update script but so far have not had any success.

    Any suggestions on why my fog server just stopped working?

    Thank you,
    Joseph Donovan



  • Thank for your answers. Due to the nature of our work and why we use this FOG server it’s unfortunately air-gapped from the internet so updates have been hard to come by regularly. The only thing that makes sense on root-cause here was one severely borked imaging operation. Even then I’m grasping at straws for a good answer on what triggered the error.

    However, I pushed through our ITsec group and got the server updated to current stable release 1.4.4 this morning which did resolve this error and it’s deploying images normally again.

    Thanks for the info guys feel free to revoke my nerd card for it being resolved with a standard update.


  • Moderator

    Is there any reason why you are running such an old release (in fog terms). The current release is 1.4.4 stable. There has been quite a bit of work put into disk imaging and resizing subsystem with FOG. I’m not going to suggest that upgrading will resolve your issue, but I question chasing something that may have already been addresses?

    (this is just my personal opinion) At this time the developers are pushing hard to get 1.5.0 (stable) released. I don’t think they have a lot of interest in reviewing older 1.3.0 RC release code.


  • Developer

    @dang_that_guy said in AWK: fatal: cannot open file error:

    I started seeing new behavior on deploying an image today.

    So what changed? Did you update FOG or your OS?

    awk: fatal: cannot open file ‘/images/XXXXX/d2.original.swapuuids’ for reading (no such file or directory)

    If this is not a typo in d2.original... I suspect you either have:

    • changed the image to be “Multiple Partitions - All Disks - ID 3” or
    • installed a second hard drive to the client you want to deploy while the image having been ID 3 all the time
    • or possibly new PCs you are deploying have some kind of internal NVME PCI-E drive which FOG recognizes and because of the image type is causing the error.

Log in to reply
 

365
Online

38982
Users

10712
Topics

101679
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.