Cannot Inventory Lenovo T430

  • Hello I just received my new Lenovo T430 and I cannot inventory the machine. It looks like it freezes while scanning the power options of the laptop. I have tried to disable the CPU power management in the BIOS. It will not boot into debug mode either. Freezing at kernel_thread_helper+0x6/0x10

  • If it helps I am running FOG on top of Ubuntu 12.04 LTS server with no GUI. Also, it helps to make sure your linux is fully updated. In ubuntu use the following commands.

    sudo apt-get upgrade
    sudo apt-get update

  • I just read the entire post and I will explain what the issue I was having was.
    Prior to updating the Kernel I was able to inventory normally only when I forced the graphics to intel only. Fog was freezing when Nvidia optimus was chosen in the BIOS. New with the update I can inventory normally with the Optimus graphics or discrete chosen in the BIOS. FOG works perfectly for both the T430 and the T430s. To update the Kernel you will have to go to the web interface and in FOG settings there will be a Kernel update option.

  • The latest kernel fixed the issue. With the Nvidia chipset you can now inventory normally.

  • Moderator

    Have you tried the latest kernel added by Jian a few days ago?

  • Bump,

    My company is ordering these by the wheelbarrow. Any updates regarding this issue?

  • I have a Lenovo t430 that i am having this same issue with. Anyone found a solution? The only thing i saw was Chris Sodey’s answer but he didn’t explained what he did.

  • [quote=“Chris Sodey, post: 9186, member: 1418”]I am now able to image the T430 w/nvidia after I updated the Kernel to the newest one.[/quote]

    What version of fog are you running? I’m running .32. Which Kernel are you using? What model T430 is it?

    I’m trying to register and capture a T430s 2353 5UU

  • I’m not sure if this is what you are looking for. I didn’t have Ubuntu laying around but I did have Mint.

    [ 0.731467] i2c-core: driver [aat2870] using legacy suspend method
    [ 0.731468] i2c-core: driver [aat2870] using legacy resume method
    [ 2.003391] VGA switcheroo: detected Optimus DSM method \ handle
    [ 2.310696] e1000e 0000:00:19.0: eth0: (PCI Express:2.5GT/s:Width x1) 3c:97:0e:14:45:79
    [ 2.310699] e1000e 0000:00:19.0: eth0: Intel® PRO/1000 Network Connection
    [ 2.310754] e1000e 0000:00:19.0: eth0: MAC: 10, PHY: 11, PBA No: 1000FF-0FF
    [ 53.397109] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 65.691344] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [ 72.351991] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 72.352219] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 79.312567] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
    [ 79.312820] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 90.188544] eth0: no IPv6 routers present
    [ 4410.498094] e1000e: eth0 NIC Link is Down

  • I am now able to image the T430 w/nvidia after I updated the Kernel to the newest one.

  • Moderator

    boot an Ubuntu LiveCD. If it loads a NIC driver that works, you can use some command lines to figure out the chipset information and the driver module name. We can probably help you get a kernel that works after we know that information.

  • Hate to bring old posts back to life but I’m having this same issue. It gets to the attempting to register host section and then appears to time out. I think it might be network related.

    I have tried the following Kernels
    The standard one I use, which I’m not really sure what it is.
    3.3.3 Core KS - someone reported this working for the T410s so I thought I’d give it a try PS

    I only have generic specs, I’ll try to get more information.

    [COLOR=#1f497d][FONT=Calibri]Product Description Lenovo ThinkPad T430s 2353 - 14 - Core i5 3210M - Windows 7 Professional 64-bit - 4 GB RAM - 500 GB HDD[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]System Type Notebook[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Operating System Windows 7 Professional 64-bit[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Processor Intel Core i5 (3rd Gen) 3210M / 2.5 GHz ( 3.1 GHz ) / 3 MB Cache[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Memory 4 GB DDR3[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Storage 500 GB HDD / 7200 rpm[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Optical Drive DVD-Writer[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Display 14 LED backlight 1366 x 768 / HD[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Graphics NVIDIA NVS 5200M / Intel HD Graphics 4000 - 1 GB[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Networking 802.11n , Gigabit Ethernet[/FONT][/COLOR]
    [COLOR=#1f497d][FONT=Calibri]Wireless Broadband (WWAN) 3G upgradable[/FONT][/COLOR]

  • Moderator

    Have you checked the working devices article on the wiki.

    post specs of device and which kernels you have tried.