SOLVED Windows error 000000f (Registry) after Clone

  • Server
    • FOG Version: 1.50
    • OS: Ubuntu 14.04
    • Service Version:
    • OS: Windows 7 x64


    We have been imaging carts of laptops all HP 6475. 4 of the carts imaged fine but 3 carts are giving a 00000000f error (Failed to load Registry) on boot. These 3 carts have a different image then the other 4. I can restore an image from the working carts to it and if I take my master image from the original computer it will boot in a computer that would not boot after being imaged.
    I ran chkdsk on original image. All Bios are set the same and using AHCI not IDE. Sent the image up a couple times to the server thinking it may have become corrupt or something.
    Can boot off a windows usb and repair the bcd and the system will boot fine but its a pain to do this on 45 computers.

  • Moderator

    @nitelife Thanks for pictures. Turns out I was on the wrong track. I thought you might still have a special partition layout that is causing this. But looks like you got that fixed already. At least we got that ruled out.

    What I am wondering about is why that boot partition (?) is 2 GB?! Have you messed with the boot partition and/or BCD?

    Which OS type is configured for that image in the FOG web GUI by the way? Possibly not Win7 which would explain the problem?!

    As well, would you please take a picture of the error screen so we see exactly what you see (the error code is definitely wrong).

  • @Sebastian-Roth
    Here is Master
    Here is Clone that wont boot

  • Moderator

    @nitelife Can you please run a debug capture task on your master. When you get to the shell type fdisk -l /dev/sda and take a picture - halt to shut it down as only need that information. Then schedule a debug deploy task for one of your clients. When you get to the shell start the deploy with fog and step through it. After it finishes run fdisk -l /dev/sda and take a picture as well.

  • Thinking its something to do with BCD, MBR or partitions since a repair boot from a Windows 7 disk fixes it.

  • Moderator

    @nitelife Would you mind taking a picture of the error and posting it here?

  • I checked my main image. For some reason there was a 100mb boot partition, then a 1gig Unallocated Partition and then a 280gb Windows Partition.

    After the system was cloned the Partitions were different on the machines that wouldnt boot. The 1gig unallocated partition was at the end of the drive.

    I fixed the partitions by removing the 1gig partition on my master image and moving the windows partition to the proper spot and expanding it another gig so there was no unallocated space.

    Sent the image back up to the fog server and still get the same error.

  • @Tom-Elliott Just noticed that the partition size on my source was not expanded to the full disk. Fixing that and sending new image up. Hoping that was issue.

  • @nitelife From the sounds of things, however, something changed in the baseline of the 4 carts, to the 3 carts. Maybe somebody is changing registry? (Can you provide a screenshot of the error you’re seeing?)

  • @Tom-Elliott They are the same model and same hardware and same os. The 4 working carts have alot more software on them like Adobe CS6 where the 3 that don’t work just have Windows and Office 2013

  • So, what’s different between the 4 carts that work, and the 3 carts that aren’t working?

  • @Tom-Elliott
    Running Version 12
    SVN Revision: 6079
    Jul 19, 2017 13:55 pm
    Was running 1.4.4 but thought upgrade might fix

  • @nitelife And you’re running 1.5.0-RC-1? (tweaked I’m assuming?)

  • No its a complete image. We don’t use sysprep as we arent that advanced yet. We use deepfreeze so all images are the same base with different software for different classrooms.

  • ARe the images sysprepped?