FOG in a mixed environment. Clients do not have PXE Boot.



  • Hey everyone,

    I’ve used FOG in the past, probably around 5 years ago. Recently we’re moving away from our interim imaging system and I’ve set up another Ubuntu server (16.04) with the latest update of FOG on it. I’m running into an issue though, as the new Dells that we’ve received (I believe Latitude 3570 is what my supervisor ordered) do not have PXE boot under it’s Legacy options in BIOS. I have a windows server 2012 R2 running dhcp and dns, so FOG isn’t managing addresses. Anyone know how I can get this machine to find and connect to FOG on startup to send it’s image? Let me know if there are any other details needed.

    Thanks in advance.



  • @george1421 Yes, thank you george.


  • Moderator

    @CoolbluHat Thank you for the feedback. Is it OK to solve this case?



  • @george1421 So I figured it out in the BIOS. The Dells are latitude 7370, and the thunderbolt netboot setting was turned off as well as USB network boot. I enabled both of those options and the laptop is now seeing the FOG server. Thank you in advance.



  • @george1421 Thank you for getting back to me so quickly. I’ll be in at work tomorrow to verify the firmware option for pxe boot, is that option found in the device manager? And to answer the Ethernet question, no these do not have Ethernet ports. I had to use an Ethernet to USB-C Dell adapter to hard wire the device to the network.


  • Moderator

    @CoolbluHat said in FOG in a mixed environment. Clients do not have PXE Boot.:

    Dells that we’ve received (I believe Latitude 3570 is what my supervisor ordered) do not have PXE boot under it’s Legacy options in BIOS

    This is very strange and I also see a contradiction.

    The 3570s should have a pxe booting option under bios (legacy) mode. If it doesn’t then I have to ask does this model have a built in ethernet port?

    I can understand if the laptop is in uefi mode (as your dhcp option 67) might make me think. If in uefi mode, you need to turn on the uefi pxe option. Its typically in the firmware on the network menu at the very top.

    [Moderator’s note: Moving post out of tutorials forum to Tech->General]



  • Forgot to mention, I’ve set up option 066 to point to the FOG server’s IP address, and option 067 to be ipxe.efi. The Dells are running Windows 10 as well, and have the latest updates run on the would-be image capture device.


Log in to reply
 

376
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.