Background not showing on PXE boot menu



  • Server
    • FOG Version: newest
    • OS: Ubuntu 14.04
    Description

    Hi,

    we use VirtualBox/Ubuntu/FOG. Yesterday i migrated virtual machine to diferent server and cant get background to show on boot menu since.

    bg.png is accesible from browser and i set permissions for bg.png to 777.

    What could be the issue?


  • Developer

    @sourceminer We don’t have restrictions on opening new threads. There is no need to post in an old one, especially if your issue is quite different! So please open a new thread for your issue and tell us more about your setup as this is most helpful in most cases: OS version, FOG version.

    Beside that: See I am not a graphic wizz but do you know about things like alpha channel, color depth and stuff like that. Maybe that image you exported can’t be handled by iPXE, maybe.


  • Moderator

    @sourceminer Does the apache error log provide any clue?

    You have the right url path and if the permissions are set correctly it “should” work.

    If you were to go into the /var/www/html/fog/service/ipxe (watch the path, because there should be a ln directory in there) and copy bg.png bg3.png does it load.



  • I know this is an old thread but cannot find any other thread regarding this and the WIKI is still out dated with the correct info. I too have the same issue.

    1. Copied bg.png into photo shop and changed a few things. Created a copy, gave it a name bg2.png file size is smaller than the original.

    2. Uploaded the file to /var/www/fog/service/ipxe as bg2.png

    3. Changed the owners to www-data:www-data permissions set to 644 (like all the others)

    4. Tried to browse to the file using http://serveraddress/fog/service/ipxe/bg2.png (does not work)

    5. bg.png does work.

    Leads me to believe these are not in the path, or that Apache doesn’t like the file for some reason.


  • Moderator

    @dugi007 Are you deploying to uefi clients? Some uefi clients can’t/don’t display the background images correctly or at all. You did reference undionly, so I assume they are configured as bios (legacy) mode.

    To answer your question, yes you can change colors but you need to be a mathematics engineer to be able to do it.

    The location is FOG Configuration->FOG System Settings->FOG Boot Settings

    Settings FOG_IPXE_MAIN_COLOURS to FOG_IPXE_HOST_CPAIRS

    These colors are defined as iPXE color pairs. The link I provided you earlier can be used to reverse engineer what the developers are using. Basically there is an index or pallet of 8 color slots defined in FOG_IPXE_MAIN_COLOURS. Then those color indexes are used in the remaining sections.

    iPXE color information: http://ipxe.org/cmd/colour

    Here is a discussion from a few years ago that gives you some great information.
    https://forums.fogproject.org/topic/3484/how-to-change-ipxe-s-and-advanced-menu-s-colors



  • tnx george for answer.

    everything is in order. In meantime i reinstaled fog and rebuilt undionly but this didnt solve the issue either…

    i don care for bg image, but i cant navigate through menu because of black background. Is there a way to change background color or background color of active menu item?


  • Moderator

    @dugi007 This is strange. Moving the FOG server vm to a new host should not cause this issue.

    Did the fog server get a new IP address with this move? The fog server should have a static / fixed IP address.

    The ipxe menu and the background image is sent from the fog server. If you call this URL confirm that IP address is accurate for the bg image.
    http://<fog_server_ip>/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00

    You should see a line like this one

    console --picture http://<fog_server_ip>/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    

    Make sure the IP addresses at that URL are consistent and correct with your FOG server IP address.


Log in to reply
 

381
Online

39.8k
Users

11.2k
Topics

106.8k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.