HP Workstations require host kernel arguments



  • Hey all,

    Trying to figure out the best way to resolve an issue that has to be done on the several HP Workstations that we have. In order to capture an image or deploy an image the machine has to be registered and then the host kernel arguments has to be set to: acpi=off

    Is there a way to have these arguments used just for a single image instead of having to register each device? Basically, I would like to plug any machine into our network PXE boot the machine and tell it to deploy an image. I can’t do that right now as it hangs until I register and perform the actions I explained above.

    Any ideas?

    Thanks everyone!



  • @george1421 I have removed the the global parameters and still exhibiting the same behavior. It is weird that this happened right after I made that change. I think something might have gotten corrupted, but I am not sure what to do at this point.


  • Moderator

    @quinniedid does it do this same when you manually register the host, set the kernel parameters to acpi=off ? Or does it only do this with the setting in the global parameters?



  • Also found that the PC will now not boot to the hard disk. It will count down from 3 and then blink and start the count down again. I have no idea what is going on.



  • I made that change. I went to test it and now both the background image on the PXE boot menu will not show up and when I select deploy image it never gives me a list and will just go back to the menu.

    Any ideas?


  • Senior Developer

    Set the argument in:

    FOG Configuration Page -> FOG Settings -> General Settings -> FOG_KERNEL_ARGS, this will cause the arguments to take place regardless of registration status.


Log in to reply
 

376
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.