Blank management page and no fog database created on Red Hat



  • Server
    • FOG Version: 1.4.4
    • OS: Redhat
    Description

    I am trying to install FOG 1.4.4 on a clean installation of redhat but when I get to the part where I am supposed to go to serverIP/fog/management and click install/upgrade the page is just blank. If I tell the installation to finish, it completes without error but I am still unable to get the management page to display. During my own troubleshooting, I have found that after the installation, no fog database has been created in mysql as well.

    At one point I suspected that the httpd service might be the problem so I did a clean installation of the OS and just installed httpd. With that installed, I am able to go to the server IP address in a browser and get the apache landing page, however after I run the FOG installation, going to that same IP address gives me a completely blank page, just like the management page.

    I suspected that maybe the lack of a fog database might be the cause of the blank page so I have tried manually creating a blank fog database but that did not get the pages to behave any differently. At the end of the FOG installation, it makes a backup .sql file that is supposed to be a backup of the database. I tried using the commands to restore a fog database to import that backup file but that did not help get the page to load either. I have a working 0.32 FOG server already so I tried making a backup of its fog database and restoring it to the FOG 1.4.4 installation but that didn’t help either.

    I have verified that the mysql password for root is blank and that the FOG installation settings reflect this as well.

    I ran the command ‘tail -100 /var/log/httpd/error_log’ after a clean installation of both the OS and FOG 1.4.4 and these are the results:
    [Thu Jun 29 21:23:57 2017] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Jun 29 21:23:57 2017] [notice] Digest: generating secret for digest authentication …
    [Thu Jun 29 21:23:57 2017] [notice] Digest: done
    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib64/php/modules/gd.so’ - libX11.so.6: cannot open shared object file: No such file or directory in Unknown on line 0
    [Thu Jun 29 21:23:58 2017] [notice] Apache/2.2.32 (Unix) DAV/2 PHP/5.3.17 mod_ssl/2.2.32 OpenSSL/1.0.1k-fips configured – resuming normal operations
    [Thu Jun 29 21:24:13 2017] [error] [client x.x.x.x] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 132
    [Thu Jun 29 21:24:19 2017] [error] [client x.x.x.x] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 132
    [Thu Jun 29 21:24:24 2017] [error] [client x.x.x.x] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 132
    [Thu Jun 29 21:25:21 2017] [error] [client x.x.x.x] PHP Fatal error: Cannot create references to elements of a temporary array expression in /var/www/html/fog/maintenance/create_update_node.php on line 25

    One other odd thing that I have noticed is that at the very beginning of the FOG installation, I see these lines:
    mkdir: cannot create directory /run/rpcbind': No such file or directory touch: cannot touch/run/rpcbind/rpcbind.lock’: No such file or directory


  • Moderator

    @SquidgyHobo RHEL 5.3 isn’t supported by FOG.

    RHEL 5.3 also it went EOL from Redhat Jan 2011. I would not even use that in my environment since it is susceptible to a handful of nasty and well publicized vulnerabilities.

    RHEL / Centos 6.5+ and 7.x are currently supported, as well as the Debian variants.



  • That version of PHP was installed by the FOG installer automatically so I assumed that was the version it required.

    I am using RHEL 5.3 (Tikanga).


  • Moderator

    What version of rhel are you using?

    PHP version 5.3 is a bit old too, but lets start with what version of rhel your using.


Log in to reply
 

354
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.