driverinstall.sh won't get host info



  • Server
    • FOG Version: 1.4.3
    • OS: Debian 8.8
    Description

    Hi everyone,
    Not really sure if this is the right section but there goes:
    up to a few days/week ago, we had our modified version of driverinstall.sh copy the drivers according to the model of the host as seen in the fog inventory under system product.

    we used to get this info through a wget command in the script (found somewhere on this forum I think or maybe the wiki)

     wget -q -O /tmp/hinfo.sh "http://${web}service/hostinfo.php?mac=${mac}"
    

    Now it won’t return anything…

    I tried to run the command with a hard coded server and mac address

    http://myfogserver.mydomain/fog/service/hostinfo.php?mac=48:4d:7e:fa:XX:XX
    

    and the resulting hinfo.sh is an empty file. When I run this same command through a browser I get a “Cannot view from browser” message and that’s about it…

    I also tried replacing the driverinstall.sh script with a backup one from two month ago to no avail so I,m almost sure it’s not someone tinkering with the script.

    I’a at a loss here, I’m not sure if this is due to the last update as I don’t manage server updates here and can’t seem to remember when the las update was.

    Maybe upgrading to 1.4.4 will fix this, but as I said, I don’t manage the upgrades.

    Thanks and have a nice day.

    Seb



  • @george1421

    Awesome! It works!

    Thanks a lot.

    I’ll have a look at dmidecode when things settle down a little thanks.


  • Moderator

    @Seb-B said in driverinstall.sh won't get host info:

    wget -q -O /tmp/hinfo.sh “http://${web}service/hostinfo.php?mac=${mac}”

    This url has changed a bit. An additional security test has been put in place to keep random url requests to this script. You will need to modify your call to pass an empty user agent to get pass this check.

    wget -q -U '' -O /tmp/hinfo.sh "http://${web}service/hostinfo.php?mac=${mac}"

    This should work.

    FWIW: You can also use dmidecode to get target computer info too. There are updated scripts in the tutorials section that show how to use dmidecode.


Log in to reply
 

488
Online

39006
Users

10720
Topics

101778
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.