Error after changing Max Clients on Node(s)

  • Server:
    • FOG Version: 1.4.2/1.4.3
    • OS: Ubuntu 16.04
    • Service Version: 0.11.12
    • OS: Windows 7

    After changing max clients in our nodes, I ran into the issue that snapins and images would not sync. The log for both images and snapins shows the following error:

    Type: 2, File: /var/www/fog/lib/fog/fogftp.class.php, Line: 463, Message: ftp_login(): Login incorrect., Host:  Username: fog

    After some digging through these forums and finding the same error (via a different cause), I have changed the passwords to match on:
    • .fogsettings: on main FOG
    • Node: (Storage Management > Management Password
    • GUI: FOG Settings > TFTP Server > FOG_TFTP_FTP_PASSWORD
    • CPU: fog user password

    After performing the above:
    • received same error after restarting main FOG
    • received same error after restarting node FOG
    • received same error after re-installing (and restarting) main FOG

    After re-installing and restarting FOG on the node, the issue was resolved and syncing again began to again work. I re-installed on the second node and syncing to that server was also restored.

    Not sure if I’m missing anything as the issue came up again when I additionally changed the Max Clients on the node (and main FOG). (The first time this happened it was late and in reaction mode - so I was not able to pinpoint the cause). The second time, it was the only change made and I noticed the same error and issue appearing - so I am assuming it is related to the Max Clients change on the node (via GUI).

    The resolution for me was same; to re-install the node, not main FOG - though I also did re-install main FOG.

    I am wondering if there is something I have overlooked or missed to prevent this from happening again… perhaps a permission change? I am worried to change max clients again as we are rolling into summer and things are currently back to normal and working as expected (wonderfully). Will be able to break again after the summer refresh to get more details if needed.

    Anything to help find the root cause or to look at prevention is appreciated.

    Thank you for all the great work.


  • @mtanigawa lol, what would you suggest to make it infiltrate better? I can change the article if you can come up with something better.

  • @Wayne-Workman
    Thank you. Yes, that was read several times. 🙂 Seems it didn’t infiltrate the brain properly enough to be effective.

  • @mtanigawa said in Error after changing Max Clients on Node(s):

    I did read in bold about that and thought I had removed the password and denied saving for fog.

    Probably this:

  • @Tom-Elliott
    Thank you for the quick reply. I am sure it is what happened the fist time. I will properly give myself a double face palm.


    I did read in bold about that and thought I had removed the password and denied saving for fog. In the assumption that it did auto fill the second time - would updating with the same password still result in the error?

    I have changed all passwords to be the same - aside from sql, so if autofill did kick in, it would have entered the same password…

    In any case, things are working and if I am feeling brave enough, I will try again from a clean browser or incognito.

    Thank you for you time.


  • You likely have autofill on for your browser and reset your storage nodes password