Blank page on web interface



  • Server
    • FOG Version: 1.4.3
    • OS: Ubuntu 16.04
    Client
    • Service Version: /
    • OS: /
    Description

    Hi folks,

    this is our first try with fogproject.
    We want to install a fog server which shares images to clients.
    It is some kind of project-work at school.

    After several fails we arrange to install a ubuntu 16.04 Server with a fog 1.4.3 system on a virtualbox to share win10 images.
    The installation works fine.
    Afterwards we want to log in the web overlay on “localhost/fog/management” but get a blank page with no information. We even tried “ip-address/fog/management” but this way the browser ended up loading for hours.
    Notice: Our fog server gets a static IP-Address, cause DHCP already avaible, but not yet implemented.

    We need help :-(


  • Moderator

    @FiSi said in Blank page on web interface:

    Please tell me it is possible to do that with fog 1.4.3

    After all of this, sorry its not possible…

    Just kidding, yes Win10 is possible both in legacy (bois) mode and uefi modes. UEFI modes are a little problem but is more on the hardware side than win10. Many new win10 systems are not coming with ethernet ports built in, so this means you must use an approved usb ethernet adapter to make it work.

    One last comment. It is possible to setup root with a password as long as the password in the .fogsettings file is the same exact as what you set root’s password to. If you change then you need to rerun the fog installer.


  • Senior Developer

    @FiSi It’s possible in in 1.3 and up.



  • @george1421 We do the “ALTER…” commands, like in the original post, except the “remove unattended-upgrades” command. I hope its fine that way.

    After we did it the line “snmysqlpass=” was not empty like expected!
    So we deleted it manuelly and rerun the installer now.

    And it works!
    Thank you very much!! :)
    Awesome how stupid we are actually… Just cause of the password… We tried so many things, nevermind.

    One last little question:
    Our task is to imaging win10 machines… Please tell me it is possible to do that with fog 1.4.3 :-)


  • Moderator

    @FiSi What I was trying to find out is if

    1. You changed the password for root
    2. The /opt/fog/.fogsettings had the correct password to access the database.

    The ALTER USER 'root'@'127.0.0.1' IDENTIFIED WITH mysql_native_password BY '' command from the developers post should have reset root’s password back to nothing. If you followed this then the root password should be nothing <blank>. The fogsettings file must be set correctly. If it is not or the .fogsettings file is not accurate to what is needed to login, please fix it so its correct and rerun the installer.



  • @george1421 said in Blank page on web interface:

    mysql -u root -p

    Well yes, the page is blank.
    And if we try to connect to the mysql database we have to type in a password :-X
    … May we just have to delete the password for the root?
    Could you tell us the right command to do that? Can we just delete the password after “snmysqlpass=” in the .fogsettings or what is right :D


  • Moderator

    @FiSi said in Blank page on web interface:

    192.168.1.100/fog/management/?node=schema

    Well I can tell you that the above page means fog want you to update the FOG database tables. This screen gives you a blank page?

    Can you login to mysql database server with mysql -u root -p without providing a password? It does appear that the fog web gui can’t access the mysql database for some reason. Did per chance you change/set the password for mysql database access for root?



  • @george1421 We try that “ALTER USER…”-fix
    We did all like told us to, but we still get the same issue - seems like nothing changed :-(

    Little note: If we try to connect to the web overlay, the address has changed afterwards automaticly to e.g. 192.168.1.100/fog/management/?node=schema
    if this helps…
    We also get the HTTP ERROR 500 - like guessed…


  • Moderator

    @FiSi The actual text helps other forum members find this thread if they have the same issue as you. You can’t easily search a picture.

    With that said, this sounds like the issue posted here: https://forums.fogproject.org/topic/10006/ubuntu-is-fog-s-enemy

    Follow the guidance in the first post and then if you still have issues the very last post. Lets see if that addresses your issue.



  • @george1421 The main OS is Debian, so no need for putty :-)
    Here you are… (and it is all greek to us :D)

    0_1498131386423_Bildschirmfoto zu 2017-06-22_13-35-35.png

    We copied the whole screen, just to be safe


  • Moderator

    @FiSi The short answer is yes that is the file. And I see errors, but they are just off the screen in the snap. Can you copy out the PHP Fatal errors and post them directly into the thread. If its not easy for you, you can use putty to connect to the FOG server over ssh. From putty you can click and drag text to copy.



  • Thanks for your fast answer…
    We are a bit short im time for the project so we are happy for any help we can get :-)
    Do you mean to

    tail -f /var/log/apache2/error.log

    ?

    Here is a picture of the last lines in the error.log with that command
    (192.168.1.100 is the IP of the fog-server)

    0_1498128765588_Bildschirmfoto zu 2017-06-22_12-50-31.png


  • Moderator

    Welcome to the FOG Forums.

    Its disappointing that you have problems with FOG installation. We have seen a few issues with ubuntu lately that causes FOG some pain.

    To start debugging the white screen issue (which means that the fog webgui isn’t happy) lets look at the apache error log. I’m a rhel guy, but I think the log is in /var/log/apache2. You want to tail the error log to see why php stopped processing.

    Just a point to mention. For the FOG server you MUST assign a static IP address. The FOG management system does not enjoy having its IP address changed after FOG is installed. For PXE booting to work you must have a dhcp server setup and configured to send out dhcp options 66 and 67 to allow pxe booting.


Log in to reply
 

357
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.