How to add bnx2x firmware to kernel

  • Hello!

    I have a PC with a network card (Broadcom 57811) 10Gb fiber. When boot by network (BIOS legacy mode) (PXE filename: undionly.kkpxe) an error appears as it can not load the firmware bnx2x To solve it I have tried two options:

    A: I downloaded the 4.11.6 kernel to compile it with this active module (make menuconfig> Broadcom support 587XX)) and an error appears with initram when booting. Using the init.xz file that comes with FOG by default.

    B: I downloaded the 4.11.0 kernel and copied the configuration file from kitchensink.conf to .conf to compile it, adding the firmware file “bnx2x-e2-” to the firmware / bnx2x folder. When you boot it again the error appears that it can not load the firmware.

    I have no experience with the Linux kernel or boot images initram.
    How can I solve that?

    Thank you very much!

  • @Tom-Elliott It works!

    But I get the message of the IP address of the interface eth0 repeated, as if IP search several times with the same itnerfaz.

    Thanks a lot!

  • Senior Developer

    Can you try the same commands again?

    Apparently I wasn’t thinking lastnight and I accidentally had -el where it should’ve been -e2.

  • Senior Developer

    @ccrespi I’ve updated the 4.11.0 kernels to include this firmware. I will, soon, be building newer kernels but from now forward the configs should have this setting defined as needed.

    To give a test please run:

    sudo mkdir -pv /var/www/fog/service/ipxe/backup
    sudo mv -v /var/www/fog/service/ipxe/bzImage* /var/www/fog/service/ipxe/backup
    wget -O /var/www/fog/service/ipxe/bzImage
    wget -O /var/www/fog/service/ipxe/bzImage32

    Run a test by booting the machine and keeping us posted. Thank you

  • Moderator

    @ccrespi Very good, this shows us the error IS in the FOS linux kernel. The FOG kernel developers should be able to address this for you.

  • 0_1498112322047_photo_2017-06-22_08-06-21.jpg

  • Moderator

    @ccrespi said in How to add bnx2x firmware to kernel:

    (PXE filename: undionly.kkpxe) an error appears as it can not load the firmware bnx2x

    Its unclear from your posting if this is an iPXE kernel (FOG Menu) issue or a FOS issue (with the kernel of you speak). As Tom suggested posting a clear picture of error will give us the context of the error message too (almost as important as the error).

  • Senior Developer

    I need the exact error message you’re seeing. Please load up the default 4.11.0 kernel and grab a picture of the error message.

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.