Can't add new hosts via web gui



  • Running Fog .32 on Fedora 14 on system that has been working fine for over a year. Reboot made no difference. I can upload and download images from/to existing hosts, [B]but I can’t add new hosts.[/B] Fedora is set to install all new security updates automatically.

    GUI and everything else seem to works fine, I just can’t add new hosts. Using same login I always use.

    I suspect that some security update overwrote a fog setting or something, but I’m not sure where to look. Any help would be greatly appreciated.

    Update:
    I can add a client via the [B]Perform Full Host Registration and Inventory[/B] method. Just the GUI method doesn’t work.



  • Problem seems to have resolved itself. May have been between keyboard and monitor.

    I just checked the access and error logs but didn’t find anything that made sense to me. I cleared the logs and tried creating a host through the web GUI and it didn’t work. No error message, it just closes like it worked.

    The problem might have been that I was using the MAC address for the name. Apparently that isn’t allowed even though I remember the full host registry and inventory doing that on its own.

    Anyway, it just worked twice with a random hostname and a MAC address so it appears to to be working correctly. I swear this didn’t work yesterday, however.

    Thanks very much for taking a look at this.


  • Moderator

    What happens when you try to manually add a host using the web interface? Do you get an error, a blank screen, or does it look like it works but nothing is added to the list of hosts?

    Have you checked the apache logs (both access and error) to see if there are any clues?


Log in to reply
 

428
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.